Unable to set RTC time.

Hi all,

I’m trying to setup the RTC on an Adafruit datalogger shield which is connected to an Arduino Leonardo board.

Now, during the soldering process, I mistakenly soldered one of the stacking headers in the incorrect position (see pic below). Luckily, it was for the digital I/O pins which I will not utilize.

Anyways, I followed the instructions from here and I managed to set the time initially. However, after 2 weeks of not using Arduino (cell battery is attached to the shield), the is way off and I couldn’t reset it using,

rtc.adjust(DateTime(2017, 8, 3, 3, 0, 0));

The time remains incorrect. There was no error messages when I run the script. I wonder if it’s because I didn’t wire the digital pins? Looking at the datalogger’s schematics I don’t see how it could affect timing.

What readouts do you get from the RTC? Is it always the same value or does it change as you would expect?

Did you measure the voltage of the battery? What value do you get?

There was no error messages when I run the script.

The library you're using does not check result codes so it won't detect problems that might exist on the I2C bus.

You should cut SJ1 and SJ2 if you use the shield on the Leonardo. Otherwise the pins A4 and A5 might disturb the I2C bus.