Uno R3 mit 2,4" Touchscreen Set

Hallo Forumgemeinde,

hat jemand diese Kombi bei sich im Einsatz Uno R3 mit 2,4" Touchsreen Set Arduino kompatibel ?

Ich bekomme das Display beim besten Willen nicht zum laufen, während mir die anderen bestellten Displays (1,8" SPI oder das LCD 20*4 mit I2C) keine Probleme bereitet haben.
Meine Versuche beschränken sich erst einmal darauf, überhaupt das Display zum Laufen zu bekommen (ohne Touch, SD-Karte)

So wie ich das ich mit meinem Anfängerwissen verstehe:
Das Display hat 8Bit-Parallel (kein SPI) und das Shield gibt mir vor, dass beim UNO

  • Die digitalen Ports an D0 bis D7 angeschlossen sind
  • RS=A5; WS=A4; LCD_CS=A3; RESET=A2

Getestet habe ich etliche Libraries von UTFT bis TFTLCD-Library-master, wobei entweder nur SPI unterstützt wird, oder beim ILI9341 nur 16Bit oder die digitalen Ports festgelegt sind und nicht diesem Shield entsprechen.
Getestet jeweils mit den zugehörigen Beispielsketch und den Konfigurationen im Sketch oder den auszudokumentierenden Dateien der Library.
Daher habe ich noch keinen Sketch gepostet. Vielleicht sehe ich den Wald vor lauter Bäumen nicht und habe daher bei der Konfig was verpennt, aber vielleicht kann mir jemand helfen bei der Auswahl einer erfolgversprechenden Library? Imerhin ist diese Kombi ja als Bestseller gekennzeichnet 8)

Gruß Patklit

EDIT
Natürlich vergessen, bei den üblichen Versuchen habe ich keine Fehlermeldungen beim Kompilieren, die Sketche welche unter “TFT01-3.2 Arduino Graphic Library” zu finden sind (Hinweis bei der Beschreibung des Shields) laufen auch nicht.

Suche mal in den Beschreibungen der einzelnen Komponenten nach einer passenden Arduino-Bibliothek. Wenn Du nichts findest, frag den Shop-Betreiber.

DrDiettrich:
Suche mal in den Beschreibungen der einzelnen Komponenten nach einer passenden Arduino-Bibliothek. Wenn Du nichts findest, frag den Shop-Betreiber.

Den Weg hatte ich zuerst versucht und mit hier gelandet
Shield bei elecfreaks.com
Die dort aufgeführten Demos sowie den Sketch auf der Wiki-Seite von elecfreaks haben bei mir nicht funktioniert.

Den Shop hatte ich angeschrieben und hatte die Antwort alle Liquid Crystal Sketche von Arduino und von Adafruit und Adafruit ILI9341 Library bekommen, letztere funktionert doch aber nur mit SPI oder?

Dann würde ich die Ware umtauschen bzw. zurückgeben und eine entsprechende Bewertung abgeben. Das sollte den Anbieter eigentlich zu einer substanziellen Hilfe bewegen.

Wenn das Shield nicht defekt ist, könnten eventuell andere Pins benutzt werden. Die genaue Belegung kann man ja ausmessen, und dann mit der Belegung in den Beispielen vergleichen.

Reicht die Stromversorgung aus?

Stromversorgung wäre auch noch eine Idee, allerdings erwarte ich jetzt einmal , dass wenn dies schon als Set verkauft wird, diese Kombination auch dann so läuft. :confused:

Der Anschluss ohne Shield direkt an den UNO (der auf jeden Fall funktioniert) steht noch aus, ich habe erst einmal Lebenszeit verbraucht um die Kombintion zum Laufen zu bekommen.
Die Pinbelegung vom Shield habe ich aus "EF02033-schematic-2.4-v2.pdf", daher die Zuordnung wie im ersten Post geschrieben.

Die oberflächlichen Hinweise vom Shop haben jedenfalls nicht geholfen :angry:

Also mal Display ohne Shield probieren, wenn sich dann zeigt, dass das TFT nen Schuss weghat beiße ich mir gepflegt in den Allerwertesten.

Danke Dir! :slight_smile: