Uno rev 3 fails to upload

Getting the : avrdude: stk500_recv(): programmer is not responding

This is an uno rev 3, my system is running windows 8.1 and I'm connected via I think usb 2.0, but might be usb 3.0

Under tools it automatically selects uno as the board and under com ports two are listed, one with arduino uno in parenthesis, so it appears to see the board.

I tried restarting the computer, disconnecting and reconnecting the board and hitting the reset button.

As far as the sketch is concerned, for simplicity sake I decided to just upload an empty sketch to reduce the factors that could be causing this problem

void setup() { // put your setup code here, to run once:

}

void loop() { // put your main code here, to run repeatedly:

}

Have you tried loopbacking?

Instructions are here: http://forum.arduino.cc/index.php?topic=73748.0

If you have tried, did it work or not, if it did not it might be the chip on your UNO, they are pretty cheap to replace if that is the case.

Samuel

Are you sure there is nothing connected to TX RX pins?!

check the driver: go to control panel and check if your arduino under unknown devices, or if there is any notification

There was something connected to the tx rx pins, I tried removing everything so it's just the board and it still won't work even after going through the loopback. Is it possible I bricked the board? I assume I need a new one? More importantly, how do I avoid doing this next time? I only need it to have 14 on/off switches plugged into it, so don't use digital pins 0 and 1?

Now I am wondering if this is a driver problem. How can I tell? where is the windows 8 64bit driver?

Start>Control panel>Device Manager Is there any notification or unknown devices there "under ports or universal bus controller"?!

If yes try to setup the driver manually right click>properties>update driver> then navigate to c:> Program files(x86)>arduino>drivers> there is a ZIP file extract everything you can find the old drivers choose "arduino uno.inf"

So to remove the driver as a possible problem I decided to connect this to an OSX machine to see what happened. Same problem. Remarkably all machines I connect it to can tell the port it is on, so some of the components are working, but it can't upload. I am really thinking I have faulty hardware, but suspect I did something to ruin it. Is this thing easy to ruin if you attach things to it improperly?

It's not easy to burn Arduino! well if you need any help with your driver msg me for teamviewer meeting

narzan: It's not easy to burn Arduino! well if you need any help with your driver msg me for teamviewer meeting

I am wondering if I static killed it, I didn't make any effort to avoid static while handling it.

Is there anything else I can try to do to verify if it is good or not?

read this article or this

Thanks. I think I will start this whole project over (with a new uno) and begin with making sure I can upload to it (if it turns out the original uno is still good I am -certain- I can find another use for it)

I still believe your Arduino is alive :) anyway good luck

Is the yellow light supposed to be solid or flash when the board is connected?

If there is a code inside; yellow LED must be solid, and the green LED too, if you press the reset button the yellow one will flash 4-5 times fast then always solid

narzan:
If there is a code inside; yellow led must be solid, and the green too, if you press the reset button the yellow one will flash 4-5 times fast then always solid

Is there a way to make a board go back to factory default?

Read this article ;)

I'm frustrated that there is no factory default. I bought a second board and got it to upload, the initial board still no go. Either I broke it or I looped it but at any rate I'm ready to move on. Thanks for your help.

:) you are welcome

Returning an Arduino to factory default is done by re-burning the bootloader onto it. You can do that using the Arduino IDE and an ISP programmer (or another Arduino as ISP programmer). I suggest that as first thing to try if you want to revive the bad board. If you re-burn the bootloader and that shows successful but you still can upload a sketch to it, you can upload sketches using the ISP programming method instead of USB from now on. If you can't re-burn the bootloader, you could replace the ATmega328 chip.

Since you mentioned you have a new board, you could actually swap the ATmega328 chips on the 2 boards, and see if the problem follows the chip, or stays with the bad board.