Upload sketch duemillanova linux eee usually fails

I made a test sketch to blink the LED. I got "programmer is not responding" errors when I tried to upload the sketch to the arduino. I kept trying to do it over and over again, sometimes pressing the reset button, and eventually I did get it to work. Then I tried again and it didn't work. I got it to work again, but I seem only to be able to upload one out of four times when I try.

I am using an Arduino duemillanova with a Linux (xandros) EEE PC 1000 netbook.

I think I had a problem on installation:

When I installed the required packages prior to installing arduino, I got this error message:

Errors were encountered while processing: /var/cache/apt/archives/linux-libc-dev_2.6.26-13_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

Then I proceeded to install arduino anyway, and as I stated above, uploading occasionally works but usually doesn't.

I tried to complie avrdude myself in case that was the problem but the confugure script fails:

configure:2206: gcc conftest.c >&5 /usr/bin/ld: crt1.o: No such file: No such file or directory

I do have gcc installed...

Any ideas?

Millie