Upload to board issue...

Hello... I have problems with the uploading of my project. Here is the error message:

Arduino: 1.8.11 (Windows 8.1), Board: "Arduino Uno"

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Marvin\Documents\Arduino\libraries -fqbn=arduino:avr:uno -ide-version=10811 -build-path C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739 -warnings=none -build-cache C:\Users\Marvin\AppData\Local\Temp\arduino_cache_107376 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA-1.3.0.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino5.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\Marvin\Documents\Arduino\Wassersteuerung\Wassersteuerung.ino C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Marvin\Documents\Arduino\libraries -fqbn=arduino:avr:uno -ide-version=10811 -build-path C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739 -warnings=none -build-cache C:\Users\Marvin\AppData\Local\Temp\arduino_cache_107376 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA-1.3.0.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino5.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\Marvin\Documents\Arduino\Wassersteuerung\Wassersteuerung.ino Using board 'uno' from platform in folder: C:\Program Using core 'arduino' from platform in folder: C:\Program Detecting libraries used... "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10811 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard" "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\sketch\Wassersteuerung.ino.cpp" -o nul Generating function prototypes... "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc-ar" rcs "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\core.a" "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\Stream.cpp.o" "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc-ar" rcs "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\core.a" "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\Tone.cpp.o" "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc-ar" rcs "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\core.a" "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\USBCore.cpp.o" "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc-ar" rcs "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\core.a" "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\WMath.cpp.o" "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc-ar" rcs "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\core.a" "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\WString.cpp.o" "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc-ar" rcs "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\core.a" "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\abi.cpp.o" "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc-ar" rcs "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\core.a" "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\main.cpp.o" "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc-ar" rcs "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\core.a" "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\core\new.cpp.o" Archiving built core (caching) in: C:\Users\Marvin\AppData\Local\Temp\arduino_cache_107376\core\core_arduino_avr_uno_0c812875ac70eb4a9b385d8fb077f54c.a Linking everything together... "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc" -w -Os -g -flto -fuse-linker-plugin -Wl,--gc-sections -mmcu=atmega328p -o "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739/Wassersteuerung.ino.elf" "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739\sketch\Wassersteuerung.ino.cpp.o" "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739/core\core.a" "-LC:\Users\Marvin\AppData\Local\Temp\arduino_build_415739" -lm "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-objcopy" -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0 "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739/Wassersteuerung.ino.elf" "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739/Wassersteuerung.ino.eep" "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-objcopy" -O ihex -R .eeprom "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739/Wassersteuerung.ino.elf" "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739/Wassersteuerung.ino.hex" "C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-size" -A "C:\Users\Marvin\AppData\Local\Temp\arduino_build_415739/Wassersteuerung.ino.elf" Sketch uses 860 bytes (2%) of program storage space. Maximum is 32256 bytes. Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes. An error occurred while uploading the sketch avrdude: ser_open(): can't open device "\.\COM3": The system can not find the stated file

Please help me, I have no idea...

PS: I had to short the message, because it was to long.

Select the port of your Arduino from the Tools > Port menu. If that menu is grayed out or the port of your Arduino board is not shown then one of the following may be the cause:

  • You may need to install the driver for the USB-serial chip on your Arduino. Determine which chip is used on your Arduino and install the driver.
  • You may be using a charge-only or defective USB cable. Test your cable on another device to confirm that it works for data.

Sometimes the port will be labeled with the board name in the menu. Other times it will not. If you don’t know which port is your Arduino, you can find it like this:

  • Unplug your Arduino board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu.
  • Plug your Arduino board into the computer.
  • Tools > Port - The new port listed in the menu is your Arduino board.