WiFi101 reconnection problem


What is the best way to reset WiFi101 as a whole?
I'm switching from Client mode to ServerAP (that works), to Client again.
When I set WiFi.end() and try to reconnect - it fails
Strange thing is that it sees the signal strength but fails to connect.
I have seen lots of discussions about reconnecting in these forums but no solution (except for hard reset)

There were a couple more pointers about re-connects too.

My MKR's have been rock solid at re-connecting since I did the firmware upgrade.
They also drop out considerably less now as well.

Tried updating to the newest version.
I think it is the going from server to client is the problem.
Gonna test the functions separated from the project

Tried ? or succeeded ?

Quick video on what was supposed to happen here.

Also ensure that the boards package is also updated via board manager. (thats not the same as firmware)

Well there was no change after successfully updating (in reconnecting after switching from ap server) after the update.
And the whole arduino ide was freshly installed with all the boards.

For now I did a hardware reset solution because I needed to hand it in for testing (the project itself)
When I will retrieve it back with all the test data, will try reconnections again.

I am also facing the same issue again. WiFi re-connection problem even after updating to following :

Arduino IDE - 1.8.3
WiFi module firmware version - 19.5.2
Library version WiFi101 - 0.14.3


My MKR1000 project also disconnects from WiFi and hangs until I do a power reset. I have code that is supposed to detect loss of WIFI connection and then try to reconnect. Similar code works for two other projects based on ESP8266WIFI. With the ESP8266 projects I can reboot the WIFI router and both projects reconnect and start working again. I have never have to power reset my ESP8266 projects! Not so with the MKR1000 based project. Other people seem to be OK with hardware resets once and a while (every 1-2 weeks) but not me. My MKR1000 project is a WiFi temperature sensor that controls my furnace through Home Assistant. When the MKR1000 project hangs, the temperature reading is not updated and the furnace can be stuck ON or OFF which is dangerous if if am away on vacation.

I am using versions:
Arduino 1.8.2
SAMD Boards 32bit ARMCortx-MO+ 1.6.14
MKR1000 19.52
WiFi101 0.14.3

I am disappointed that the newer MKR100 technology is not as reliable as the ESP8266 and will replacing the MKR1000 if I don't get an inspiring comment to this post.

Just had my first disconnect that did not re-connect but it took over 4 months and I only checked when I had read this again.

I did get a power spike around that time so am thinking it was a fluctuation issue.

Same issue here. My arduino mkr1000 successfully connects to WiFi, however fails to connect to server to POST variables to php page. I had flawless connections for the past two months, and for the past week my arduino has been hanging at the server connection.

Any updates on a solution?

Not from me i’m afraid.

Would you care to post your sketch ? If you do post it please use code tags ( </> )

There is nothing special about the sketch, I use the same technique to connect to server as the WiFiWebCient.ino example sketch, except the fact that I only want to send information via POST not GET. That takes place after the server connection anyways, so that isn't the issue.

I tried to run the example sketch to see if I did something wrong, but that hangs as well.

Regardless its often useful to have a frame of reference to be able to duplicate an issue.
So sharing the sketch can be a very useful bit of information.

I have a spare MKR1000 on my test board ( 15 varieties of Arduino / esp8266 ) that I often throw sketches at from forum users.


I have got a problem in updating the wifi-Firmware, too.

Update from senor-datas to Thingspeak-channel only works twice, than, after about a minute, MKR1000 looses wifi-connection. Trying to ping the MKR1000 from the mac-terminal works while sending the 2 updates with a delay of 30 sec., after that -> timeout.

I have read something about firmware update to WINC1500 19.5.4, but the Arduino-IDE only gives me the 19.5.2 - any ideas how to update to 19.5.4?


A quick video of the firmware update here

Hi @Frodo1980

You'll have to download the nightly IDE version to get the firmware update tool that contains 19.5.4. IDE version 1.8.5 does not contain it, however the next IDE version will include it.