[WIN] Aggiornam. compilatore IDE 0022-0023-1.0 all'ULTIMA VERSIONE ATMEL

Confermo appieno quanto afferma Astro, a parte l'aggiunta indispensabile del core, io ho sempre lavorato ESCLUSIVAMENTE con l'IDE 0022 originale; come ho già detto nel post precedente la modifica di Astro l'ho inserita in una cartella specifica che rinomino all'occorrenza, ma in genere lavoro con il software originale, quindi anche la toolchain, e non ho altre installazioni "parallele" di software ATMEL. Da qualche mese ho installato anche l'IDE 1.0.1 ma con lo stesso "schema" organizzativo.

Mi fido di voi, non avendo Windows non posso controllare il motivo per cui a ER non vada.

leo72: Mi fido di voi, non avendo Windows non posso controllare il motivo per cui a ER non vada.

boh... Oggi provo a reinstallare tutto, speriamo bene...

Ho provato a compilare lo sketch che hai fornito usando l'IDE 1.0.2 e l'ultima release del core ATtiny, l'errore che ottieni non è del IDE e/o toolchian, è la libreria software serial che non va bene per gli ATtiny, a seconda del modello scelto ottieni errori di allocamento memoria oppure di registri non riconosciuti. Vado a memoria, ma non si era già parlato del fatto che la software serial ha problemi con gli ATtiny ?

appunto quello che pensavo io, è solo quando uso la software serial che ho quei problemi, ma allora perchè su linux va?

?R: appunto quello che pensavo io, è solo quando uso la software serial che ho quei problemi, ma allora perchè su linux va?

Non uso Arduino con Linux quindi non posso darti una risposta, però sotto Windows è fuori dubbio che il problema è proprio la software serial.

Non ho mai usato la software serial però sono ragionevolmente sicuro che Leo abbia più volte consigliato la new software serial, in quanto risolveva un problema be noto che esiste anche sotto Linux.

[quote author=Michele Menniti link=topic=96976.msg1010069#msg1010069 date=1353927708] Non ho mai usato la software serial però sono ragionevolmente sicuro che Leo abbia più volte consigliato la new software serial, in quanto risolveva un problema be noto che esiste anche sotto Linux. [/quote] beh ma nel nuovo IDE la SoftwareSerial è quella che era la NewSoftSerial.... comunque lo stesso problema l'ho avuto anche l'anno scorso e l'ho risolto passando a linux

?R: beh ma nel nuovo IDE la SoftwareSerial è quella che era la NewSoftSerial.... comunque lo stesso problema l'ho avuto anche l'anno scorso e l'ho risolto passando a linux

Il problema si risolve utilizzando micro con la seriale hardware :grin: Io sconsiglio sempre l'emulazione software dell'UART, oltre a mettere molti paletti e consumare tempo cpu è poco affidabile.

?R: [quote author=Michele Menniti link=topic=96976.msg1010069#msg1010069 date=1353927708] Non ho mai usato la software serial però sono ragionevolmente sicuro che Leo abbia più volte consigliato la new software serial, in quanto risolveva un problema be noto che esiste anche sotto Linux.

beh ma nel nuovo IDE la SoftwareSerial è quella che era la NewSoftSerial.... comunque lo stesso problema l'ho avuto anche l'anno scorso e l'ho risolto passando a linux [/quote] e va bene, tanto comincia l'inverno, non patirai il caldo vestito da pinguino :) scherzi a parte non so dirti ma non credo che nessun utente WIN abbia mai usato questa lib, vedo che se ne parla spesso.

[quote author=Michele Menniti link=topic=96976.msg1010078#msg1010078 date=1353928247]

?R: [quote author=Michele Menniti link=topic=96976.msg1010069#msg1010069 date=1353927708] Non ho mai usato la software serial però sono ragionevolmente sicuro che Leo abbia più volte consigliato la new software serial, in quanto risolveva un problema be noto che esiste anche sotto Linux.

beh ma nel nuovo IDE la SoftwareSerial è quella che era la NewSoftSerial.... comunque lo stesso problema l'ho avuto anche l'anno scorso e l'ho risolto passando a linux [/quote] e va bene, tanto comincia l'inverno, non patirai il caldo vestito da pinguino :) scherzi a parte non so dirti ma non credo che nessun utente WIN abbia mai usato questa lib, vedo che se ne parla spesso. [/quote] ahaha ma poi soffrirei il caldo d'estate :P il problema è che adesso non riesco ad avere un OS linux, se non virtualizzato... Non c'è un modo di caricare il programma precompilato? sui PIC saprei come fare a caricare il file .hex, ma qui su arduino fa tutto l'IDE da solo...

Faccio chiarezza. Ai tempi dell'IDE 0022 non si poteva usare la SoftSerial perché incompatibile con i Tiny. La NewSoftSerial, con alcune modifiche, supportava questi micro.

Poi è uscita la versione 1.0 del software di Arduino e la NewSoftSerial è stata integrata nell'IDE come sostituta della vecchia SoftSerial. Nelle ultime release è stata resa compatibile con il core di Arduino. Ma attenzione, e questo lo dico fin da quando l'ho saputo anch'io sul thread del core Tiny stesso, ci vuole specificatamente la versione 0100-0015 del core, le precedenti NON funzionano del tutto con la SoftwareSerial.

Ora, se si combina l'IDE 1.0.2 ed il core Tiny 0100-0015 la compilazione della SoftwareSerial deve andare in porto, senza nessun tipo di errori, neanche quelli segnalati da astrobeed.

A riprova allego uno screenshot preso sul mio portatile proprio ora dove ho compilato lo sketch di ER che ha pubblicat qui
Come vede, compilato con successo su Attiny84 a 8 MHz e Attiny85 a 8 MHz.

PS: ricordo che la SoftwareSerial NON compila a 1 MHz ma solo ad 8 MHz per i Tiny.

allora io adesso ho sitemato tutto (IDE, core, hardware...) ma ancora non riesco a compilare quel codice su windows... se aggiorno la toolchain può cambiare qualcosa?

?R: allora io adesso ho sitemato tutto (IDE, core, hardware...) ma ancora non riesco a compilare quel codice su windows... se aggiorno la toolchain può cambiare qualcosa?

Ci vuole un utente Windows che faccia la prova, per capire se ci sono dei problemi sulla toolchain stessa o se i problemi sono relativi al tuo sistema.

?R: allora io adesso ho sitemato tutto (IDE, core, hardware...) ma ancora non riesco a compilare quel codice su windows... se aggiorno la toolchain può cambiare qualcosa?

La toolchain non c'entra nulla, il problema è la libreria che invoca hardware non esistente oppure richiede più memoria di quella disponibile, ovvero la software serial fornita con windows non funziona con gli ATtiny, apri una issue ufficiale e forse tra un paio di mesi te la sistemano :)

Domani faccio una prova con un PC non mio con Windows XP e poi ti faccio sapere.

leo72: con un PC non mio con Windows XP

Dopo che hai finito disinfettati bene le mani... non hai idea di quanti virus ci potrebbero essere su XP. ]:D ]:D :grin: :grin: :grin:

PaoloP: Dopo che hai finito disinfettati bene le mani... non hai idea di quanti virus ci potrebbero essere su XP. ]:D ]:D :grin: :grin: :grin:

Purtroppo così deve essere, è a lavoro da me e non posso cambiarlo. Cerco solo di difenderlo al meglio con tutto quello che posso (antivirus, antispyware, firewall HW e SW).

sono leggende metropolitane, io non ho mai preso un virus su windows :)