0x62 != 0x0c problem, although the IDE still uploads code onto the Arduino


I guess a greeting is in order, so hello! I have been working on making an ambient light sensor with an Arduino UNO, making it so some data showed up on an LCM1602 LCD. Up until yesterday, I had been setting it up, and kept on testing it under different light conditions from then on till now. However, just from one moment to the other, a problem happened when uploading the code with just the static message to be displayed on the LCD changed.

Sketch uses 5,172 bytes (16%) of program storage space. Maximum is 32,256 bytes. Global variables use 306 bytes (14%) of dynamic memory, leaving 1,742 bytes for local variables. Maximum is 2,048 bytes.

avrdude: verification error, first mismatch at byte 0x0000 0x62 != 0x0c avrdude: verification error; content mismatch avrdude: verification error; content mismatch

The first part ("sketch bla bla bla") appears in white, with the second one in red, which, I guess, means there's been a problem. I've tried looking up the problem online, and in different forums, but I really can't find an answer. I tried some of the recommendations, like resetting the Arduino with the on-board button, but to no avail. Also, something caught my attention. Whereas other users' problems made the Arduino incapable of having any code at all uploaded to them, my Arduino accepted new code. Still, this being a new Arduino, with less than a month of use, it made me nervous that something is wrong, because red letters anre never good, now are they? haha Any help would be really appreciated. Oh, and I'm repeating this JIC, I can still upload and make code work, the problem doesn't affect that at all. But still. Thanks in advance! TheArtist

I should probably upload my code JIC hehe forgot about that.

Proyecto_F_tabladelux.ino (1.23 KB)

Proyecto_F_tabladelux.ino (1.27 KB)

I’ve been seeing that error show up on these forums lately - 0x62 and 0x0c at 0x0000, specifically.

I do not know of anyone having achieved enlightenment on it’s cause, much less a solution.

Would be interesting to get to know the Hardware and software details. If your configuration uploads successfully and the only issue is the error message - this could be a temporary workaround for others who are not lucky even to upload anything to their boards.

And maybe one day somebody can really find out a real technical solution after having identified the cause behind that behaviour.

So, pls tell us: - your operating system incl. Version (build) - IDE version - selected/installed AVR board library version


Sorry for necroing the thread, my bad.

My OS is Windows 10 Version 10.0.14393 Build 14393.

My Arduino IDE version 1.6.12.

I´m afraid I don´t know what the AVR is.


I have 4 ATmega328p and giving me the same error. somebody brought them to me to hack. I think they disable the SPIEN register therefore you can not upload any code but the latest code in the chip keeps running.

google SPIEN for more information.