20 X 4 Display Help

I have a 16 X 2 display from Batron and got it to work no problem, apart from it being very small. So I got a 20 X 4 display by Batron and thought it would work no problem as the data sheets were virtually identical. Unfortunately the 20 X 4 display does not work, I thought it may have been a faulty display and got a replacement from Farnell but now its obviously something I have done. The connections are 100% continuous and read 0 Ohms with an AVO, I am getting +5 and 0V to the display, the contrast pin is going to a 10k pot (i have had it to both extremes and in the middle of its range), I've checked that I haven't got the pin numbers wrong way round etc... Could someone have a look at the datasheet and tell me if its a compatibility problem and how it could be rectified. I am using the standard LCD library "hello world" example (changing the rows and columns of the display in the setup() ).

Working display datasheet (16 X 2): http://www.farnell.com/datasheets/1536553.pdf

Not working display datasheet (20 X 4): http://www.farnell.com/datasheets/1536545.pdf

Kind Regards,

Gunn

Try these steps and provide enough information as required by this thread:

http://arduino.cc/forum/index.php/topic,102266.0.html

Thanks Liudr, I got that shaft encoder to work :).

Like I said in the previous posts, I have checked basic issues such as connections and wiring mistakes...I am 99.9999999% confident that it is nothing of that nature. The datasheets have been provided aswell :)

Here is a pic of my rig, I plugged the 16 X 2 display into the exact same connections on the bread board and it worked no problem (on its own and in parallel to the 20 X 4).

Uploaded with ImageShack.us

How about disconnect all data/control lines and just see if there is going to be black blocks if you adjust the pot?

Just tried that, absalutely nothing happens. On my AVO I read 5 volts on the display pcb +5 and 0V test points, yet still no display :( I had tried this test with the first 20 X 4 display and nothing happened, hence why I thought it faulty and sent it back.

Theres a small number of these things around that require a negative voltage on the contrast pin to get them to display. You could try a 1.5V battery with the + end to Gnd and the - end to the contrast pin or pot to test it.

WELL DONE :D!!! It needs a negative voltage…stupid display! Thanks for the help

A right pain in the backside to make a tidy permanent job of with an Arduino........