able to burn bootloader but cannot upload sketches to arduino pro mini(s)

recently ive been designing my own arduino and wanted to see what it was like to program via FTDI so Id know how to get it working with my new arduino compatible device. I have multiple arduino pro minis specifically they are old chinese knock offs that follow the adafruit schematic. Ive spent the past few hours trying to trouble shoot and so far ive tried. * using arduino as isp *using this FTDI * desocketing an arduino uno and connecting right to is rx and tx *using an arduino uno as isp to reflash the bootloader and test it that way. which worked purfectly but didnt allow me to upload sketches still. *switching between all of the different board types in the arduino ide to test if Ive got the wrong one. *pressing, rapid tapping, and caressing the reset button.

sadly none of this worked and im quite stumped. the error message doesnt give much info but here it is anyway if anyone wants it (this is what happens when I try to upload)

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xd7

thank you guys so much for being a great resourse through all of my learning with arduino. cheers.

Hi, you need to go to preferences and turn on the verbose setting, so the full error message can be viewed.

I recently had a similar issue but with a 328PB IC. After loads of messing around, I found the way which worked for me was to upload the Bootloader via a USBasp and then load the sketch via a FTDI. You can use the USBasp to upload the sketch but it will removed the bootloader, although the fuse setting remain intact.

Which Pro Mini are you using, the 5V 16MHz or the 3.3V 8MHz?

How did you burn the bootloader? And which bootloader did you install?

What are the board settings for when you're trying to upload the sketch via FTDI?