Adafruit Pro Trinket - 5V 16MHz - keine USB Verbindung

Kennt sich jemand mit dem Pro Trinket von Adafruit aus?

Ich bekomme keinen sketch geladen:

avrdude: usbdev_open(): did not find any USB device "usb"

Boards lt. Anleitung installiert, ominöse im Hintergrund laufende Windows Software installiert.

Wenn ich USB anstecke macht mein Win10 auch DingDangDong.

Was mache ich falsch? :o

Hmmm, lt. Anleitung soll rote LED für 10s blinken. In dieser Zeit soll Bootlader aktiv sein.

War ja klar: Bei mir blinkt rote LED dauerhaft....Grrrr.... :)

Oh oh, hab’s befürchtet: Das Teil kennt keiner!?

Hab wohl wieder mal Mist gekauft… :grin:

Über den FTDI Anschluß hab ich jetzt mit einem Programmer den Sketch laden können.
Nur über den USB geht nix - naja: genau wegen dem USB hab ich das Teil gekauft…

Der ATmega328 der auf der Platine verbaut wurde, hat keine USB-Schnittstelle. Diese wird vom Bootloader emuliert. Ich weiß nicht ob dadurch ein spezieller Treiber (nicht der Standart Arduino Treiber) erforderlich ist. Ich kann Dir nur sagen Du mußt Dich an die Anleitungen halten. Der angebotene Treiber ist nicht für WIN 10 spezifiziert. Ich weiß nicht ob er auch für WIN10 funktioniert. Frag mal nach oder versuchs mal mit einem anderen Rechner mit Win 7-8.

Ansonsten fürs mnächste mal rate ich Dir zu einem Kauf eines MICRO- MICRO PRO. Der hat einen ATmega32U4 drauf mit USB Hardware-Unterstützung. Da funktioniert auch die serielle übertragung von daten (was ich beim Pro Trinket bezweifle, aber mich auch irren kann)

Grüße Uwe

Ja, das ist richtig: Daten können nicht zurück auf den ser. Monitor über die USB gesendet werden - das steht auch so drin. USB soll nur für den Sketch-Upload funktionieren.

Und stimmt: W10 steht nicht bei dem Treiber - grrrr - lebt adafruit noch hinter dem Mond? :slight_smile:

Hatte bisher auch immer den Pro Mini in Benutzung. Wollte einen mit USB nehmen - hätte wohl besser auf den Nano setzen sollen - weiß auch nicht was mich da geritten hat… :o

Müsste man nicht USBtinyISP als Programmer auswählen?

The cool thing about the bootloader on the Pro Trinket is it just looks like a classic USBtinyISP AVR programmer. This makes it easy to use with AVRdude or Arduino IDE with only minor configuration changes. Before you start, you may need to install the USBtinyISP USB drivers

stoni99: Hatte bisher auch immer den Pro Mini in Benutzung. Wollte einen mit USB nehmen - hätte wohl besser auf den Nano setzen sollen - weiß auch nicht was mich da geritten hat... :o

Willst du tauschen? :)

Das habe ich auch schon probiert. Geht auch nicht.

Merkwürdigerweise geht seit der erstmaligen Benutzung des FTDI die beschriebenen 10s Blinken (Bootlader-Bereitschaftsanzeige) beim USB-Anschluß. Hmm... Aber keine Übertragung.

Tauschen? Niemals! mein guter Trinket... ;-) Nee, mit FTDI geht es ja.

Hab mal Adafrüchtchen zw. W10 & Driver angefragt...

Whandall: Müsste man nicht USBtinyISP als Programmer auswählen?

Wer nicht will der hat schon. ;)

Haaaalt !

Kommando zurück !

Ich hatte vergessen das Board von (FTDI) auf "Pro Trinket 5V/16Mhz (USB)" umzustellen.

Jetzt geht es mit USBtinyISP als Programmer !!! Freu & rumspring :grin:

Also für alle die mal einen Pro Trinket laden wollen:

  • Boards lt. Anleitung installieren
  • Windows Software lt. Anleitung installieren
  • das Richtige Board auswählen (kann man schnell durcheinander kommen - stehen einige drin) (aufpassen ob mit USB: "Pro Trinket 5V/16Mhz (USB)" oder FTDI übertragen wird: "Pro Trinket 5V/16Mhz (FTDI)") !!!
  • bei USB den USBtinyISP als Programmer auswählen - bei FTDI hatte ich AVRISP mkll als Programmer
  • nicht vergessen: bei USB kurz vor dem upload reset am Trinket drücken damit rote LED 10s blinkt (Bootladerbereitschaft)

Is alles a bisserl gombliziert - würde das nächste mal libber den Nano nehmen... :grin:

Danke für eure Tip's...

Da sieht man wieder was von

Das habe ich auch schon probiert. Geht auch nicht.

zu halten ist.

stoni99: Is alles a bisserl gombliziert - würde das nächste mal libber den Nano nehmen... :grin:

Vieleicht auch einen MICRO :)

Aber das alles zeig 2 Sachen:

  • Wir können nicht hellsehen:

  • Wie lösen Deine Probleme.

Grüße Uwe

Naja: Ich hab als erstes den Upload über USB getestet. Da konnte ich den Trinket nicht durch Reset in den Bootzustand bringen (rote LED blinkte immer). Genau da hatte ich auch schon mal mit USBtinyISP als Programmer getestet - da ging nix.

Erst nachdem ich 1x erfolgreich über den FTDI geladen habe blinkte nach Reset 10s die rote LED. Dann hatte ich aber mit USBtinyISP nicht mehr getestet. Erst nach deinem Hinweis - und dann fälschlicherweise das erste mal mit Pro Trinket 5V/16Mhz (FTDI)".

Ihr vermutet doch nicht etwa das stoni einen Fehler gemacht hat?! :grin: Nieeemaaals! :grin:

Aber das zeigt, das man durchaus alles 2 oder 3mal testen sollte. Ich gelobe Besserung...

Whandall: Da sieht man wieder was von

zu halten ist.

Ich trau mich kaum zu fragen:

Ich habe beim Rumspielen den Pfad zum Einbinden der Trinket-Board´s aus Versehen gelöscht.

Ja: Ich bin zu blöd diesen wieder zu finden. :confused:

Kann mir bitte jemand den Pfad unter Datei-Voreinstellungen-ZusätzlicheBoardverwalterURL´s geben.

Müsste so: http://adafruit....trinket...pro...json heißen.

Diesen hier hatte ich probiert, den will die IDE nicht:

“Fehler beim Herunterladen von https://www.adafruit.com/package_adafruit_index.json

Hmm…

Nach ca. 100 grauen Haaren mehr: Hab es gefunden!! :grin:

Die Strolche vom Adafrüchtchen haben eine falsche Adresse geschrieben, welche aber richtig verlinkt ist:

falsch (so geschrieben): https://www.adafruit.com/package_adafruit_index.json

richtig: https://adafruit.github.io/arduino-board-index/package_adafruit_index.json

siehe