Arduino CNC: Stepper motor doesnt spin. it just vibrates

Hi All, I am trying to assemble an Arduino CNC plotter. The stepper motors doesn't spin but they just vibrate. Need help in this regard. Hardware: Arduino UNO Stepper motor shield V3 from Protoneer. Motors 17HS3401 drv8825 stepper motor driver 22V 3A DC power supply Code: GRBL From: https://github.com/DIY-Machines/CNC-DrawingMachine Chillipepper for uploading the G Code. I have tested the stepper motors, power supply using switches in H Bridge layout. Tested the driver, shield, motors and power supply using simple code. Verified the pins on the GRBL CPU_map file. experimented with the pot settings of the current limiter. But the motors still doesn't work they just vibrate when using GRBL.

Quite often simple vibration will indicate a wiring issue between the motor and the driver.

Chase out the windings to be sure you have everything correct (lots of help on google for that)

It can also indicate a dead or dying driver which can happen if you plug/unplug motors with a live board !

Start with just one single motor and issue commands manually to it.
Don’t forget to power down before making ANY changes.

My own preference is for this version of GRBL as it is more compliant.

Thanks Bob. I have tried the same wiring/shield and drivers to test the motors it worked, But micro stepping was not working when using simple testing codes. I have been careful when plugging/unplugging. I have good experience with that :slightly_frowning_face:. Here are few things that I already tried out, I was trying with Benbox I started off with L293D drivers, with 18V supply, burnt up two driver boards. Again motors just vibrated. Moved on to DRV8825 drivers on a CNC Shield V3 from protoneer. Benbox didn't work Used simple codes to test the motor and driver functionality. This too started heating up too quickly when testing on a single motor and would shut down just after 2 rotations and will start working after cool down. Tuned the pot, connected 2 drivers and 2 motors along with a fan the motors would run for little longer,. Benbox would loose all the pin configs on it I could only move 1 axis in 1 direction using the buttons provided on the application, So decided to use GRBL. erased the EEPROM using the clear EEPROM sketch(Please let me know if this is not correct) uploaded the GRBL. this too failed. Took up a new board and set of new drivers(Still old wires/shield and motors) and tried again. didn't work. I posted my problem here.

I Will try the GRBL you suggested.

As for the program to control the shield I use either lasergrbl or UGS from windows and have found them both to be quite reliable as well as easy to use and set up.

Although for very simple moves you can even use most serial terminals.

There are a gazillion hits if you search for stepper judder, shake, vibrate.

Most will home (pun intended) you in on specific causes and cures.

Getting into CNC related projects can be a short but steep learning curve with the advantage of being extremely rewarding once you get the basics down. That is regardless of whether it is drawing, laser, or more advanced CNC machining or 3d printing as they all use the same principles in some way.

A thread here may also give you some useful tips and a couple of giggles if you can work your way through it.