Arduino COM3 Port Not Showing Up

I've been experimenting with my arduino and everything has been working just fine for a few weeks but suddenly today, I am no longer able to see it under ports. I don't hear any windows "connect sound" when I plug it into any computer (tried on several computers that have Arduino installed), and I tried a brand new usb cable on it too. The only thing I can think of that could've caused this is that I might've made some sort of improper circuit configuration which smoked the USB type B port on the arduino.

I was working on a project that involved a servo, but I wanted a separate power supply, so I used two 9V batteries to create an 18V supply and a voltage regulator to step down to 6V which connected to the servo. The pwm cable of the servo is connected straight to the board. I had to connect the ground of the 18V supply to get the motor to actually work. However, the arduino was still powered off of the computer. After testing the motor successfully, next time I plugged it in, the device didn't get recognized and here I am. However, the arduino still receives power from the computer and moves the motor back and forth when plugged in, running the same sketch that was last on it. I'm wondering if I should've connected the ground of the regulated 6V supply (yellow wire) instead of the ground of the 18V supply.... I added a link to a picture of my circuit. I appreciate any help you guys give!

Always power up the controller first. Then power up the peripherals.

Qutote:
I'm wondering if I should've connected the ground of the regulated 6V supply (yellow wire) instead of the ground of the 18V supply

They ought to be the same.

Please post a wiring diagram of the first setup.

When you think you are having problems relating to the USB, please reboot the PC and try your tests again and report if that fixes the problem or symptoms are the same.
Paul

Hi Paul, I've rebooted the computer and also tried it on multiple computers and windows doesn't even acknowledge that a device is connected let alone an Arduino.

Does a different USB cable make a difference?
Paul

I don't have experience with circuit diagram software so I drew this up in microsoft paint but it gets the job done: https://imgur.com/a/LvF0SvK

Yeah, I've tried multiple cables and multiple computers and still no results. Also uninstalled and reinstalled the arduino software. That's why I'm starting to wonder if the arduino USB type B port itself is toast.

Hi @aero_engineer_48.

By your report, the chip may have a problem with the atmega328 and USB interface.
Or chip may be damaged or has skecth problems.

The original arduino uses the atmega16U2 chip, which has a sketch inside it.

If possible, for testing, use another arduino on your PC.

RV mineirin

Yes, it's very easily done, the damage possibly, I mean.
A final check might be to look in Windows Device Manager (old Windows, but still in Win 10) or devices in Win 10 settings)
It might be possible to salvage the 328 chip and see if it can be contacted as a barebones chip using the ISP pins.
There used to be a version of the Uno called a Ruggeduino (Rugged Circuits) that went through all ways of protecting the delicate bits from mis-wiring etc.

For a couple dollars you can replace the MCU on the Uno board.
If it works toss the old IC.
If it doesn't work then both ICs are probably good and can be used for breadboard projects and the rest of the board can be tossed instead.