Arduino is not showing in COM ports

Hello! I am pretty new to Arduino so if I missed something I am deeply sorry in advance. My problem is that when I plug in my Arduino UNO board it is shown in the Device Manager as USB2.0-Serial and no new COM ports are shown after plugging although there is COM1 and LPT1 even if the Arduino is not plugged. I discovered this problem after getting the "avrdude: stk500_recv(): programmer is not responding" error and tried to find a solution for it. I have tried to solve it for some hours now so any help is greatly appreciated. Thanks everybody in advance!

Maybe the problem is in the drivers.

I doubt you have an Arduino UNO! You probably have a clone, provide a link to where you bought it!

I have tried like everything about the drivers but nothing really worked.

Yeah now that I am looking at it I think it is a clone. Since the school borrowed it to me I do not know where did they buy it but I assume it is this one since they are completely the same. Klon Arduino UNO R3 ATmega328P CH340 mini USB | dratek.cz

No problem

See here : https://learn.sparkfun.com/tutorials/how-to-install-ch340-drivers/all

1 Like

No.

The school lent it to you. Or you borrowed it from the school.

I see there has already been a link to the solution so I will just leave you with the grammar lesson.

Yeah my bad I was so frustrated from this problem that I even forgot how to speak or type in English properly.

1 Like

Thank you very much! Will try and hope for the best.