Arduino Mega 2560 comes up as usb composite device AND 1.3M Webcam in device man

hi team,

I have a mega 2560 16u2, I was using it attached to a ramps 1.4 board for my 3d printer, mid print it suddenly ceased operation. I have tried using both a windows 7 and windows 8 laptop, with 7 both the webcam and usb composite device show up, with windows 8 just the composite device.

There is nothing connected to the board (I removed the ramps 1.4) other than the USB cable.

When it is plugged in both the green and orange light stay solid.

When I go into Arduino 1.0.5r2 I can select the board type, however I the comport list is greyed out.

I have tried using the reset button.
I have tried installing the drivers again, both with the board plugged in and with it not plugged in - any advice on uninstalling the drivers manually would be appreciated
I have tried multiple usb ports
I have tried 2 USB cables
There is no visible physical sign of electromagnetic charge or burnout on the board at all.
I can 'disable' or uninstall the webcam entry however this does not make a difference, and when I do and then scan for hardware changes it is re-installed.

Assistance would be appreciated as I cannot for the life of me work out what has gone wrong, or, given the board has power and can talk somewhat to pcs, how to reconfigure it.