Arduino Mega 2560 v3 issue vs. Uno Revision 3 when using SIM800L v2 GSM Module

I'm having the following situation: When I connect the Arduino Uno Revision 3 to the SIM 800L v2 GSM Module everything works, if I test the code from here:

I'm powering the GSM module with an additional power source.

But if I run the same code (except the values of the pins) on a Mega 2560 v3 board, only the sending of the SMS and initiating voice calls works. Receiving SMS is not working. From what I can see for the Mega board case the data sent from the GSM Module does not reach Arduino. No data is available on the serial connection. Some data should be visible in the Serial Monitor, even when sending SMS. (It is visible on Uno board and not on Mega, even if Mega commands the GSM module to send successfully the SMS to my phone).
I've tried a lot of various pins combination from the board. I have even connected the GSM Module VDD pin to 5V or to the IOREF pin from the Mega board. (For Uno it works without using the VDD pin.) If I measure the voltage between the RX or TX pins and the GND the value is 4,95 V. Same value between the IOREF pin and GND.
Why it is working on UNO board and not on the Mega?
Is SoftwareSerial library failing on Arduino Mega board?
Do I need to perform some jumpers setting on Mega?
Is there an issue with TTL/ voltage levels?

I think this wire should go to that pin? Please post a simple schematic showing how you have it wired?

Not all pins on the Mega support software serial, but why would you use software serial when the Mega has 3 additional hardware serial ports.

Cattledog is right, regarding the software serial! It works on pins 10 and 9, but not on D23-D53 or on those for serial communications. Too much combinations to test on this board! :slight_smile: Thank you for your support, guys!

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.