Arduino Micro Windows XP serial communication not working

I searched the forums and googled Arduino serial problems but didn't find anything similar to mine, at least with Arduino Micro + Windows.

I just bought an Arduino Micro and started by running basic tests on it to see if it works properly.
No problems occurred during installation. I started Arduino 1.0.3 chose the correct board and serial port and uploaded the blink program. Everything worked as expected.

Then I moved on to test the serial communication. I uploaded this code:

int led = 13;

void setup()
  pinMode(led, OUTPUT);

void loop()
  digitalWrite(led, HIGH);
  digitalWrite(led, LOW);

The upload was successful, the board was reset and then I opened the serial monitor and checked the baud rate to be 9600. Then things started getting weird:

At the two first times when the pin 13 LED is HIGH the TX LED blinks but nothing is received by the serial monitor. After this the TX LED does not blink but the 13 LED stays HIGH for longer than a second, maybe two. Nothing is written into the serial monitor at any time. When I close the serial monitor the 13 LED continues to blink at a normal pace.

I reset the board and tried again. The same thing happened. I re-uploaded the sketch and tried again. The same thing happened.
Does anybody have any suggestions as to what might be happening and how it could be fixed?

Feel free to ask more about my configuration if I failed to mention something important. Thank you for your responses in advance.

I just ran your sketch here, and runs without a hitch, so at least you know that the code is good. Did you do a very close physical inspection of the board? Which board are you using? Tested here on an UNO R3.

Which board are you using?

My board is Arduino Micro R3

Did you do a very close physical inspection of the board?

The components are really tiny on this one and it's hard to notice if something is wrong. I might as well send this back as faulty and request a new one from my supplier.

I also tested your sketch on my Arduinoi Micro and it ran fine, with the LED blinking and "test" displayed on the serial monitor every two seconds.

I tested the board with another PC with Windows 7 64 bit and it worked fine. It seems there might be something wrong with my original PC's USB ports or drivers. Thank you for your responses though.

Go in the 'failing' system and delete the "USB Controllers" from Control Panel. Shutdown the system, Power OFF and then POWER ON - reboot. Windows will restore / reload the USB Controllers in the Device Manager list automatically. Just do a reinstall of your device driver. I've had to do it with Win 7 64 bit on my laptop (this machine) and it works fine. Win 7 kinda steps on its own you know what.