Arduino nano every stuck on uploading

Hi sorry if this might be a repetitive question but all of a sudden when i try to upload any code the arduino nano every board it compiles the sketch fine but its stuck on uploading. When its stuck, i try to press the upload button again and this is the error i get (otherwise if i don't do anything it will remain in "uploading forever":

Arduino: 1.8.13 (Windows 10), Board: "Arduino Nano Every, None (ATMEGA4809)"

Sketch uses 2830 bytes (5%) of program storage space. Maximum is 49152 bytes.

Global variables use 177 bytes (2%) of dynamic memory, leaving 5967 bytes for local variables. Maximum is 6144 bytes.

Forcing reset using 1200bps open/close on port COM5

processing.app.debug.RunnerException

	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:152)

	at cc.arduino.UploaderUtils.upload(UploaderUtils.java:77)

	at processing.app.SketchController.upload(SketchController.java:732)

	at processing.app.SketchController.exportApplet(SketchController.java:703)

	at processing.app.Editor$UploadHandler.run(Editor.java:2055)

	at java.lang.Thread.run(Thread.java:748)

Caused by: processing.app.SerialException: Error touching serial port 'COM5'.

	at processing.app.Serial.touchForCDCReset(Serial.java:107)

	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:136)

	... 5 more

Caused by: jssc.SerialPortException: Port name - COM5; Method name - openPort(); Exception type - Port busy.

	at jssc.SerialPort.openPort(SerialPort.java:164)

	at processing.app.Serial.touchForCDCReset(Serial.java:101)

	... 6 more

An error occurred while uploading the sketch


sorry if this is a repeated thread but i've been searching for 2 days now and cant find a solution for this. Thanks

Hi @arnewbie. Does the Arduino IDE's Tools > Port menu identify COM5 as "Arduino Nano Every"? It should show the board name next to the port name in the menu.

yep it does, i was uploading code just fine up until this moment but beforehand I uploaded programs countless of times

Try restarting your computer. Sometimes a glitch causes the port to get stuck open and restarting fixes that.

I've tried that too, I've also tried different micro USB cables and kept getting the same error

Try pushing the restart button when uploading.
My Arduino nano for some reason stopped auto-resetting itself.

just tried that a couple of times it still doesnt work