Arduino Nano - no digital output, can only toggle built-in LED

Hi everyone,
Got my first Arduino Nano board (a clone), i'm testing it by blinking a LED.
I can sucessfully upload the code on the Arduino, but it appears there isn't any output (the LED is Always off, regardless of where it is placed from D2 to D9...), wiring is OK, ground is properly wired, LED is not damaged...)
Strangely, whenever i upload the Blink code with either pin 13 or led_builtin, the built-in LED works without any problem.

What's going on?

/MaverickRF

Can you provide the code you uploaded?
You can select all the code in the IDE and right click to copy it for the forum.

Also, did you change the usage of pin to output in pinMode before using digitalWrite on the pin to which the LED was connected?
Is the polarity of the 5mm-LED (direction in which it is plugged in) correct?
Is the resistance value appropriate?

1 Like

Hi there,
This setup works perfectly fine with an Arduino Mega 2560. LED polarity correct (short lead to Gnd), 330 Ohm resistor.
And with a typical blink sketch (a delay of 500 for my case)

An obvious test would be to connect the led/resistor to pin 13; it should flash as the built-in led.

It's not clear if you did test that.

The code doesn't seem to be a problem.
But you should have to post using code tags.
I said already that, please care next time.

Also, if it works with other Arduinos, there should be no problem with the setup.

What happens if use LED_BUILTIN in your code to connect your LED to D13?

I've tried to place the LED at D13... but what's happening is just weird: the built-in LED blinks while the 5mm one isn't even reacting... Why?

Does the LED light up when the jumper wire stuck in the D13 is inserted into 5V?

Do you have a DMM?
Check the resistance value of the jumper wire to see if it is broken.
If all goes well, measure the voltage on the Nano's output pins.
If possible, measure directly from the soldered part of the header pin.

No, the LED didn't light up even when connected to the 5V pin... I guess there must something wrong in the header pin... what could be the reason? bad soldering from the factory?
Yes i have a DMM. I'm gonna check it out...

As far as I can see in the picture, soldering the header pins doesn't look that problematic.
I'm sure there is a problem with the 5mm-LED setup side.

Same setup for Arduino Mega

:roll_eyes:
 

Sorry for the mess, guys... I've finally found the culprit: a faulty breadboard :weary:
Tried the same setup on another breadboard and everything work fine... pheww... i almost feared that my Arduino was somehow broken...

At least i want to thank you for your willingness to answer... I'm grateful

:upside_down_face:
 

You can click the solution checkbox under the most useful post (yours) to indicate to others that the issue is solved.

Are you sure you just didn’t have the led connected the wrong way around - in your last picture the connections are reversed.