Arduino nano not showing up in my computer

I connected Arduino nano to my computer and power light on nano is ON, also the "L" lights is blinking, but the computer does not show anything, nor gives any sound that something is connected to it.
Checked the USB cable and is OK. The unit is a chinese one with a WKH CH340G chip in the back of the unit. Every once in a while the computer says "USB device not recognized", but immediately goes OFF and stays like that. When the PC says "USB not recognized" the RX light turns ON.
I tried to install the driver for this chip but fails every time.
I connected another Nano to same PC and it is recognized immediately. The driver is date: 11/4/2011, version: 3.3.2011.11, signed by Microsoft Windows Hardware Compatibility Publisher

Somebody know how to fix this?

I do not know how I fixed this. I tried to reinstall the driver, reinstall the PC, uninstall the driver, uninstall the unit, etc. But now it is working !!!!
Thanks to all. This post is closed.