Arduino nano RP2040 connect not showing under port

Hello Guys,
Unable to load sketch in board,
tried to access flash by connecting ground to rec
but when i upload default blink skech there flash restart
and it is happening again and again.

Can you share a picture of your connections, please?

  1. Open your IDE and add in the "Preferences" (use both IDE versions 1.8.15 and 2.0 beta, both can
    run independently in your PC) this:
    http://downloads.arduino.cc/packages/package_staging_index.json

as shown below for "Additional boards manager URLS: "


  1. Now install the core for your board in both IDE's.
    · Tools > Board > Boards Manager
    · Search for "Arduino Mbed OS Nano Boards"
    · From the drop-down menu select latest version
    · Click "Install/update"
    · Wait for installation to finish
    · Click "Close" and restart your IDE.
    . Plug your board back to the computer and select the board and port via tools.
    See https://www.arduino.cc/en/Guide/Cores
    Note: Use a data USB cable capable of some 480Mbps and do not use a USB hub.

  2. Now plug the board to your computer, select via IDE's tools, the board and port it is connected
    to.

If the above steps fail to solve the issue, contact Arduino Support via https://www.arduino.cc/en/contact-us/


Please refer above photo for reference

  1. I made these connections
  2. Flash memory got opened
  3. Then uploaded blinking led sketch
  4. Suddenly flash memory got rebooted and sketch was gone.
  5. Tried multiple time but unable to save sketch in flash memory.

Did you do what @dozie suggested?
How did that go?

yes did but still not working

  1. I followed all steps,
    still port is not visible but I can upload blinking led sketch,
    but every time time i need to press reboot button before adding new sketch.

  2. also,
    board is visible under "Device Manager<<other devices" but with yellow error triangle.
    Tried to install drivers for board but getting error message.

  3. same problem is with flash, it unable to save data
    data is disappearing whenever I tried to save data.

  4. why my flash showing 128MB (not128Mbit) size when board spec says 16MB flash.

Where do you see that?


when I double click reset button Removable Disk(H) pops up, with memory 127 MB

Thanks for the clarification. I hadn't noticed that before. I wonder if it's a minimum recognizable value imposed by the operating system?

Still my main problem has not been solved. do you have any answer for that?
Will there be problem with board itself?
I already contacted my local vendor and he is taking back board and will check for problem.

Are you using windows vista?

No, I use windows 7

The IDE has no problem with Windows 7, which makes sense, but I wonder if there's a specific driver issue.
IDK personally, but maybe a driver guru will see this.

Also, this is a slightly different board but perhaps some of the same fixes apply. Check out this thread:

@lord-ganesha , Use IDE version 1.8.15 and carry out the steps below:

  1. downloaded "Blink.ino.elf.uf2" from https://docs.arduino.cc/tutorials/nano-rp2040- connect/rp2040-01-technical-reference

  2. place a jumper wire between REC and GND. This will open a mass storage folder with INDEX and INFO_UF2 files.

  3. remove the jumper wire between REC and GND while the mass storage folder still open.

  4. now drag the "blink.ino.elf.uf2" file into the mass storage folder. If successful, the board will be flashed with a program that blinks the built-in LED, and shifts between the red, green and blue pixels.

  5. lastly test by uploading a Blink LED sketch from the IDE after selecting the board and the port via the IDE's tools, to confirm that the board now works fine.

Didn't work for me. What worked was to do Step 1 till 3. Open Arduino IDE (Arduino 1.8.15 works fine // 2.0 beta aswell) and "blind upload" a sample Blinksketch for the Arduino Nano RPM 2040. That means just hit the upload button while no Port is selected.

1 Like

may be but not sure

I just returned board to seller for further analysis, now all hopes are on him.

already tried but didnt worked for me. I just returned board to seller for further analysis, now all hopes are on him.
Thanks arduino team for support.