Arduino Port Problems (urgent)

I recently bought two Elegoo UNO R3 boards to use in a school project with a deadline coming up soon.

I have previously purchased the exact same product from Elegoo before and it worked completely fine.

This time with these 2 new boards, having the Arduino Create Agent installed, the web IDE doesn't detect the Uno and I cannot upload anything. Going to the console shows "Serial Port Unavailable".

When I install and run the offline Arduino Uno IDE, the "port" option under tools is greyed out and so I cannot select a port to upload anything.

Going into the device manager shows "Unknown Device" when I have the board plugged in, and when I proceed to attempt to install the driver as per the Windows installation guide, I get the error message

"Windows found drivers for your device but encountered an error while attempting to install them."

"Arduino Uno"

"One of the installers for this device cannot perform the installation at this time"

When I go to the properties of the "Unknown Device" I find "This device is not configured correctly (Code 1)".

What perplexes me even more is that I tried again on a friend's laptop, and I was able to select a port under "tools" and I could upload programs no problem. I'm not sure whats wrong with my laptop in this case. Any help would be appreciated, thanks!

Nothing is ever urgent around here unless somebody has been slacking off and wants to catch up real quick before they flunk.

The web IDE supports clones so It will probably not be a driver issue unless you changed something or your computers security is too high in some way.
But you would have known that if you had looked down the list and seen the web IDE section.

Lets get this moved there for you.