Arduino running under Parallels VM [solved]

I am using Mountain Lion OSX with Parallels VM (current versions)

I have tried running Arduino 1.0.1 and 1.0.2 (for Windows) under a Parallels Virtual Machine - in neither case does Arduino recognise a Serial Port - and so neither can do an upload.

I have ensured that the USB is assigned to the Virtual Machine, and it is listed as Vendor 2341-Communication.

I have no problems running Arduino on OSX (native).

Ideas please!

Thank-you

Which Windows? Have you installed the USB driver (that comes in the Arduino download) to Windows?

Thank-you

I am running under Windows 8.

Arduino erw 1.0.2 Configure Board Drivers brings up the dialog box, but fails to install any drivers.

If I look into the downloaded install folder there are no drivers.

In W8 Control Panel there are no ports shown in the Device Manager.

If you are using Eried's forked IDEs, then you probably need to ask him about any problems, as he changes quite a lot of stuff. Try adding a question on his thread: Arduino Forum

Thank-you for your suggestion - I have sent Eried a question. Eried's version fails to install the Drivers during the IDE installation process.

However I have I also downloaded and run the 'standard' Arduino IDE for Windows, where the installation readme says that Windows will install the required drivers when the Arduino Board is first connected.

This does not happen when running Windows 8 in a Virtual Machine.

Running in a virtual machine doesn't have anything to do with your issue.

Make sure you aren't making the mistake that many people do in windows and try to install the FTDI drivers.

The Arduino Ide runs just fine - no problems so, yes, running in a VM is not the problem.

The issue is that it cannot see any Serial Ports, so cannot upload an app to the board.

I am unable to install any drivers (let alone the FTDI ).

Problem solved - W8 dos not allow drivers without signatures to be loaded - you have to go into Settings and disable this feature.

see
http://www.bryonconnolly.com/windows-8-arduino-driver-install

It appears the Parallels VM reports a cut-off device ID. Check the device ID in the device manager, then edit the inf file in the Arduino Driver subdirectory to show the same ID and it should now work.