Arduino software will not launch.

Last December, I installed windows eight. I am just now finding the need for this software again, so I installed it, and extracted it. However, when I click on the .exe file, the logo pops up on my screen, closes, and the interface does not come up. Note: this is the first installation of any arduino software onto my computer.

Any solution would be great, thank you :D

I'm not running Windows, but I think you should check compatibility issues with different Java versions (especially 32 vs 64 bit). Try installing a 32bit version. You did not specify which version of the Arduino IDE you are trying to use; I would recommend 1.0.3 unless you have specific reasons to choose 1.5 (e.g. you have an Arduino Due).

I will try installing java 32 bit, and I am trying to run 1.0.3

The arduino software still will not launch.

Try opening a command shell (prompt), go to the Arduino directory and run Arduino.exe. It still won't work, but it should give you some informative message.

I tried, and it showed no output, or informative text. However, it launched the logo like it did by simple clicking on it from the desktop.

I hope someone with fresh knowledge of Windows will come to the rescue, the only advice I can give is a bunch of pretty hopeless attempts, in no particular order:

  • Check the antivirus settings and logs.
  • Run the program as administrator.
  • Check the system event log.
  • Delete the preferences.txt file located in the Arduino directory somewhere under your %HOME% (e.g. \Users\me\AppData\Roaming).
  • From the command prompt, in the Arduino program directory try launching arduino.exe --l4j-debug.

I tried these, A document was created on my desktop. Also, preferences was not located under app data. document: CmdLine: C:\Users\me\Desktop\arduino.exe --l4j-debug WOW64: yes Working dir: C:\Users\me\Desktop. Bundled JRE: java Check launcher: C:\Users\me\Desktop\java\bin\javaw.exe (n/a) 64-bit search: SOFTWARE\JavaSoft\Java Runtime Environment... Match: SOFTWARE\JavaSoft\Java Runtime Environment\1.7 Match: SOFTWARE\JavaSoft\Java Runtime Environment\1.7.0_10 Using 64-bit runtime. 64-bit search: SOFTWARE\JavaSoft\Java Development Kit... 32-bit search: SOFTWARE\JavaSoft\Java Development Kit... Check launcher: C:\Program Files\Java\jre7\bin\javaw.exe (OK) Add classpath: lib\pde.jar Add classpath: lib\core.jar Add classpath: lib\jna.jar Add classpath: lib\ecj.jar Add classpath: lib\RXTXcomm.jar Launcher: C:\Program Files\Java\jre7\bin\javaw.exe Launcher args: -Xms128m -Xmx128m -classpath "lib;C:\Program Files\Java\jre7\lib\tools.jar;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.jar;lib\RXTXcomm.jar" Args length: 161/32768 chars Exit code: 1

I need help, and am getting frustrated with this software.

I would extract the Arduino software to it’s own folder, like c:\arduino , for example.

The log indicates the launcher is not able to find the bundled version of Java and is using the version of Java you have installed. Since you are running 64 bit windows it is launching the 64 bit version of Java.

The Arduino software is not compatible with 64 bit Java.

If you extract the software to it own folder, instead of the desktop, it should find the 32 bit version of Java that is bundled with it.

Thank you so much! It worked!