Arduino Uno not compiling,

I’m on a 2015 Macbook Pro and I’m trying to get started with Arduino Uno.

I tried the blink test and I get this error. Any yes, I read the getting started/troubleshooting guide.
I was getting a different error before (see attachment) and then read I should burn the bootloader. Well, that didn’t help anything and now I get this.

Arduino: 1.8.8 (Mac OS X), Board: “Arduino/Genuino Uno”

I am a complete beginner and just want to be able to get started, or to know if my board is broken or what.

/Applications/Arduino.app/Contents/Java/arduino-builder -dump-prefs -logger=machine -hardware /Applications/Arduino.app/Contents/Java/hardware -hardware /Users/charlesmalave/Library/Arduino15/packages -tools /Applications/Arduino.app/Contents/Java/tools-builder -tools /Applications/Arduino.app/Contents/Java/hardware/tools/avr -tools /Users/charlesmalave/Library/Arduino15/packages -built-in-libraries /Applications/Arduino.app/Contents/Java/libraries -libraries /Users/charlesmalave/Documents/Arduino/libraries -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0043 -ide-version=10808 -build-path /var/folders/yx/j_5cwvtn66ndxdck4v5nb8rh0000gn/T/arduino_build_163013 -warnings=none -build-cache /var/folders/yx/j_5cwvtn66ndxdck4v5nb8rh0000gn/T/arduino_cache_105095 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avrdude.path=/Users/charlesmalave/Library/Arduino15/packages/arduino/tools/avrdude/6.3.0-arduino14 -prefs=runtime.tools.avrdude-6.3.0-arduino14.path=/Users/charlesmalave/Library/Arduino15/packages/arduino/tools/avrdude/6.3.0-arduino14 -prefs=runtime.tools.avr-gcc.path=/Users/charlesmalave/Library/Arduino15/packages/arduino/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2 -prefs=runtime.tools.avr-gcc-5.4.0-atmel3.6.1-arduino2.path=/Users/charlesmalave/Library/Arduino15/packages/arduino/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2 -prefs=runtime.tools.arduinoOTA.path=/Users/charlesmalave/Library/Arduino15/packages/arduino/tools/arduinoOTA/1.2.1 -prefs=runtime.tools.arduinoOTA-1.2.1.path=/Users/charlesmalave/Library/Arduino15/packages/arduino/tools/arduinoOTA/1.2.1 -verbose /Applications/Arduino.app/Contents/Java/examples/01.Basics/Blink/Blink.ino
/Applications/Arduino.app/Contents/Java/arduino-builder -compile -logger=machine -hardware /Applications/Arduino.app/Contents/Java/hardware -hardware /Users/charlesmalave/Library/Arduino15/packages -tools /Applications/Arduino.app/Contents/Java/tools-builder -tools /Applications/Arduino.app/Contents/Java/hardware/tools/avr -tools /Users/charlesmalave/Library/Arduino15/packages -built-in-libraries /Applications/Arduino.app/Contents/Java/libraries -libraries /Users/charlesmalave/Documents/Arduino/libraries -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0043 -ide-version=10808 -build-path /var/folders/yx/j_5cwvtn66ndxdck4v5nb8rh0000gn/T/arduino_build_163013 -warnings=none -build-cache /var/folders/yx/j_5cwvtn66ndxdck4v5nb8rh0000gn/T/arduino_cache_105095 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avrdude.path=/Users/charlesmalave/Library/Arduino15/packages/arduino/tools/avrdude/6.3.0-arduino14 -prefs=runtime.tools.avrdude-6.3.0-arduino14.path=/Users/charlesmalave/Library/Arduino15/packages/arduino/tools/avrdude/6.3.0-arduino14 -prefs=runtime.tools.avr-gcc.path=/Users/charlesmalave/Library/Arduino15/packages/arduino/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2 -prefs=runtime.tools.avr-gcc-5.4.0-atmel3.6.1-arduino2.path=/Users/charlesmalave/Library/Arduino15/packages/arduino/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2 -prefs=runtime.tools.arduinoOTA.path=/Users/charlesmalave/Library/Arduino15/packages/arduino/tools/arduinoOTA/1.2.1 -prefs=runtime.tools.arduinoOTA-1.2.1.path=/Users/charlesmalave/Library/Arduino15/packages/arduino/tools/arduinoOTA/1.2.1 -verbose /Applications/Arduino.app/Contents/Java/examples/01.Basics/Blink/Blink.ino
Using board ‘uno’ from platform in folder: /Applications/Arduino.app/Contents/Java/hardware/arduino/avr
Using core ‘arduino’ from platform in folder: /Applications/Arduino.app/Contents/Java/hardware/arduino/avr
Detecting libraries used…
/Users/charlesmalave/Library/Arduino15/packages/arduino/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2/bin/avr-g++ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10808 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR -I/Applications/Arduino.app/Contents/Java/hardware/arduino/avr/cores/arduino -I/Applications/Arduino.app/Contents/Java/hardware/arduino/avr/variants/standard /var/folders/yx/j_5cwvtn66ndxdck4v5nb8rh0000gn/T/arduino_build_163013/sketch/Blink.ino.cpp -o /dev/null
fork/exec /Users/charlesmalave/Library/Arduino15/packages/arduino/tools/avr-gcc/5.4.0-atmel3.6.1-arduino2/bin/avr-g++: no such file or directory
Error compiling for board Arduino/Genuino Uno.

Hey all,

I found the solution here.

Sorry for the earlier post. I can't figure out how to delete it.

https://forum.arduino.cc/index.php?topic=399248.0

The community suggests editing the post title by adding a [solved] in it once you have a solution. FYI

I have also faced the same compiling issue on my MacBook Pro and to fix this error, I had updated the system, but, after the update, my macbook pro won’t turn on black screen. Now, how can I solve this Black Screen issue on my MacBook Pro?