Arduino Uno not connecting to computer through COM even though its still on

I bought my Arduino Uno a few weeks ago, and have decided to put it to use. After a while, it was working well. After a few days, I was unable to upload a project to the Arduino Uno, and after some searching, in the device manager it showed that it was a code 45 that it wasn't connected, but the cord was still plugged in. I tried to fix it by unplugging it and putting it in a different port, but it didn't work. Please help!

Code45 usually means the device is not connected properly.

Common causes are a cable not fully inserted, A faulty cable (Chinese cables are notorious for that), USB ports on computer could be failing, or the device was somehow damaged.

Bob.

I'll give you some more information. The only USB connections I have available are the ones in my Alienware gaming monitor (AW3418HW). They are the ones under the monitor not in the back of it. The cord I am using is the one that came with the Arduino Uno starter kit. I've tried putting the cord in other USB slots but it still said no connection. The lights on the Arduino are on so the cord still can send power to the Arduino. I can use the USB slots for other cords, and they work.

That only narrows it down to cord or board.

Just because it is getting power does not mean it is getting data that a fully working cord would provide.

Bob.

So it's definitely not a problem with the computer?

I don’t think so at this point seeing as you say other items work in those same ports.

Bob.

Hello Swissstuff,

Thank you for writing in Arduino forum.

First of all, I would recommend to go through the Troubleshooting guide:
https://www.arduino.cc/en/Guide/Troubleshooting#upload

Check the following points as explained in the troubleshooting guide:

  • Arduino IDE update
  • Drivers
  • Access to serial port
  • Physical connection
  • Auto-Reset (Only for Arduino Diecimila, Duemilanove, and Nano)

If all the points in the above checklist have been verified and the problem persists, we can narrow down the issue to bootloader corruped/missing or damaged/defective hardware.

To check that the bootloader is present, connect the board to power and tap the reset button quickly twice. The built-in LED should blink (fading in and out the light). If the bootloader is missing, please follow these instructions to reprogram the board:

If the board does not respond to double tap reset or you are unable to reprogram bootloader with above instructions, it is likely the hardware is damaged. If this is the case, check with our technical support to find out weather you are qualified for a board replacement or not.

I hope this helps!