Arduino uno not working. Help

Hi! I need help ASAP . i have a project due in a week and my arduino uno isnt working. Recently it didnt work in my pc, what happend was that i was doing my work, then i saved it, unplugged the uno and went to sleep, the nest day i woke up, the uno isnt being detected in the port section so i checked the device manager and it wasnt there too. It wasnt in the COM and LPT section nor in the unknown device section and the hard drive wasnt there. A day after i got a new laptop so i downloaded arduino and checked there, the same thing! It wasnt being detected in the COM or LPT, nor in the unknown device.
Can anyone help me? Is it a problem with the uno ? And the usb port is working as i use my usb's there. Help.

It could be the UNO, or the USB cable!

What was the last thing you had plugged into the UNO? Do you have ANY LEDs on the UNO when it is plugged in?

Can you take an in focus, close up image of your UNO, just in case we can see anything obvious.

What do you mean by 'hard drive wasnt there' ?

Hi missdrew! Sorry for the late reply, i brought a new USB cable when this happend, and it still didnt work.... The last thing i plugged in was a LED, i was showing my brother how it works with the blinking LED code ( without the breadboard, which explains the blinking of the yellow light in the UNO ) After that i didnt use any components on it when trying it again, and here is the photo of the UNO

I didnt mean the "hard" drive, i meant the drive that is displayed in the COM and LPT section of the device manager, sorry for the confusion :slightly_smiling_face:

@codingjedi Your board is not an official Arduino board, so try and re-install the driver for your clone board. See the driver for clones at CH341SER.ZIP - 南京沁恒微电子股份有限公司. Secondly, use a high speed data USB cable.

I agree that this is a clone board, but I don't found the CH340 and it looks like an ATmega16U2 for USB-UART is on it.

Hi dozie! Can you guide me how to install the driver for the board?

You don't need that driver (as @chrisknightley indicated) as your board does not have the CH340 TTL-to-USB converter.

Oh, then what could be the case?

Have you tried replacing the USB cable?
Does Windows take nothing action when you plug in Uno?

Yes, i bought a new one, and windows doesnt detect the uno at all, not even in the unknown device section

Do you have a jumper plug or a female-female jumper cable?

Please (electric)short the two headers closest to the USB connector on the Uno marked in this photo.
image

Then connect Uno to your PC.
Once connected to your PC, try removing the jumper.

Does Windows recognize anything?

how do i do that?

I tried it, and it didnt work, windows detected nothing, for the jumpers i have both of them

As a precaution, can you again short once and re-remove jumper the that after connected USB?

This is a method to enter DFU mode the ATmega16U2 which controls USB communication.
This should cause Windows to recognize it as an ATmega DFU Loader.

Note:
Please be careful when shorting with the USB connected.
Be careful of contact with exposed pads and other headers of overall boards!

@chrisknightley ignore my first suggestion, it is for a different clone. Try a few steps below:

  1. use a data USB cable to connect it to your PC.
  2. install the board's core via the IDE's board manager, see https://www.arduino.cc/en/Guide/Cores
  3. now double tap the reset button, if the onboard "L" LED fades in and out, try uploading a sketch like BlinkLED example to the board. If you upload successfully, tap the reset button once to exit the bootloader mode.
    Note: If this "L" LED does not fade in and out when you double tap the reset button, then your board does not have a functional bootloader.

Check the usb and connections. Check if the lights blink up.

Yes the lights blink

My pc isnt detecting the uno.... How can i upload the code....