Arduino Uno R3 Communication Problem


I had new Uno r3 for 2 months. It was working properly. However I tried about a week ago and computer no longer detects it. I did tried everything to solve that problem.Nothing happened. Finally I give my unit to shop which bought it.They told me that no problem on arduino. But it still not working.I go mad. :~Someone out there please help me.


Note:I'm using mac OSX 10.7.5 and sorry for bad English.

Can you specify what you mean when you say the computer doesn't recognize it? Do you try to upload a sketch and it fails? Or you upload a sketch and nothing happens? Plug in your Arduino and upload a sketch and check to see if the green "ON" light is turned on. Something like this happened to me where I would upload a sketch and nothing would happen and I actually felt the USB port on the Arduino start heating up. I noticed the "ON" light wasn't light up, so I knew there was probably a short or something. Turns out the ATMega chip wasn't all the way in its socket. I just pushed it back in and it worked. But if you ever feel the Arduino start to get hot or its plugged in and the "ON" light isn't green, turn it off right away to avoid damaging the Arduino.

I checked, chip inserted socket firmly. When I connect board to computer it turns on and run last uploaded program.However i won't be able to upload new program because no usbserial in serial port menu.Only bluetooth modem and bluetooth PDA sync.I think that something went wrong on USB-to-serial chip.I also waited about 20 minutes and nothing gets hot.

This is exactly what happened to me once. It's nothing wrong with your USB Serial chip. Unfortunately I can not completely recall what I did to fix it, but I'm almost positive it was just pushing the ATMega chip back into proper place. If that isn't the problem (and you are completely sure), check to make sure the USB connecter is firmly connected to the USB port on your computer and the port on your Arduino. Also check if the "ON" light is green when you connect the USB cable.

Sounds to me based on what the store told you that the problem is likely something wrong with the USB software driver installation in your PC.


thanks for the help however i tried on 3 computers 1mac, 2 xp it still does not work.Maybe I should buy a new unit. Otherwise i'm going to lost my mind