Arduino Uno with SparkFun OpenLog MicroSD code not working

Hi, everyone! I have an Arduino Uno R3, and I’ve connected a SparkFun OpenLog to it. My setup is like this:

I managed to get power to the open log, and right now, it just has one solid blue light. The text files that are supposed to be created in the microSD I’ve plugged into the open log are being created. However, when I run the sample programs, It never gets past the initial part for the SD card. The error I get depends on the sample program I get.

This is what I get when I run the SerialPort ReadWriteTest

Arduino: 1.8.13 (Windows Store 1.8.39.0) (Windows 10), Board: "Arduino Uno"

In file included from C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\SerialPort\examples\ReadWriteTest\ReadWriteTest.pde:2:0:

C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\SerialPort/SerialPort.h: In member function 'size_t SerialPort<PortNumber, RxBufSize, TxBufSize>::write(const __FlashStringHelper*)':

C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\SerialPort/SerialPort.h:583:11: error: 'prog_char' does not name a type; did you mean 'putchar'?

     const prog_char* p = (const prog_char*)s;

           ^~~~~~~~~

           putchar

C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\SerialPort/SerialPort.h:584:25: error: 'p' was not declared in this scope

     size_t n = strlen_P(p);

                         ^

C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\SerialPort\examples\ReadWriteTest\ReadWriteTest.pde: In function 'void loop()':

ReadWriteTest:26:21: error: 'class SerialPort<0, 16, 16>' has no member named 'getRxError'; did you mean 'getWriteError'?

   uint8_t e = port0.getRxError();

                     ^~~~~~~~~~

                     getWriteError

ReadWriteTest:30:11: error: 'class SerialPort<0, 16, 16>' has no member named 'clearRxError'; did you mean 'clearWriteError'?

     port0.clearRxError();

           ^~~~~~~~~~~~

           clearWriteError

exit status 1

'class SerialPort<0, 16, 16>' has no member named 'getRxError'; did you mean 'getWriteError'?

Invalid library found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\firmware: no headers files (.h) found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\firmware

Invalid library found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog: no headers files (.h) found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog

Invalid library found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_Benchmarking: no headers files (.h) found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_Benchmarking

Invalid library found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_CommandTest: no headers files (.h) found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_CommandTest

Invalid library found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_Light: no headers files (.h) found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_Light

Invalid library found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_Minimal: no headers files (.h) found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_Minimal

Invalid library found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_ReadExample: no headers files (.h) found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_ReadExample

Invalid library found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_ReadExample_LargeFile: no headers files (.h) found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_ReadExample_LargeFile

Invalid library found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_Test_Sketch: no headers files (.h) found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_Test_Sketch

Invalid library found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_Test_Sketch_Binary: no headers files (.h) found in C:\Users\sasuk\OneDrive\Documents\Arduino\libraries\OpenLog_Test_Sketch_Binary



This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Just off hand, it looks like a mismatch between the sketch and the library, i.e. the library isn't the one the sketch is written for.

Ah, I see. Do you know which code I'm supposed to use with the OpenLog?

Did you install the SerialPort library?

Did you read this all the way through.

https://learn.sparkfun.com/tutorials/openlog-hookup-guide