Arduino wifi developer edition problem

Hello I try to make turn off and turn on a led with a website thanks to an Arduino wifi developer edition card I connected the card to my router and configured it without problem.

On arduino it is well connected I tried a small code with a led everything works perfectly even if I send the code with the IP address

on the other hand this code which is the example of the Arduino_Uno_WiFi_Dev_Ed library (the library of this board) seems to doesn’t create any “webserver”

/*
File: WebServerBlink.ino
This example creates a simple web server on your Arduino Uno WiFi. It serves a
simple web page with 2 buttons that can be used to switch on and off on-board led 13.
Please type on your browser http://<IP>/arduino/webserver/ or http://<hostname>.local/arduino/webserver/

Note: works only with Arduino Uno WiFi Developer Edition.

http://www.arduino.org/learning/tutorials/boards-tutorials/webserverblink
*/

#include <Wire.h>
#include <UnoWiFiDevEd.h>

void setup() {
    pinMode(4,OUTPUT);
    Wifi.begin();
    Wifi.println("Web Server is up");
}
void loop() {

    while(Wifi.available()){
      process(Wifi);
    }
  delay(50);
}

void process(WifiData client) {
  // read the command
  String command = client.readStringUntil('/');

  // is "digital" command?
  if (command == "webserver") {
    WebServer(client);
  }

  if (command == "digital") {
    digitalCommand(client);
  }
}

void WebServer(WifiData& client) {

  client.println("HTTP/1.1 200 OK");
  client.println("Content-Type: text/html");
  client.println();
  client.println("<html>");

  client.println("<head> </head>");
  client.print("<body>");

  client.print("Click<input type=button onClick=\"var w=window.open('/arduino/digital/4/1','_parent');w.close();\"value='ON'>pin13 ON
");
  client.print("Click<input type=button onClick=\"var w=window.open('/arduino/digital/4/0','_parent');w.close();\"value='OFF'>pin13 OFF
");

  client.print("</body>");
  client.println("</html>");
  client.print(DELIMITER); // very important to end the communication !!!

}

void digitalCommand(WifiData& client) {
  int pin, value = 0;

  // Read pin number
  pin = client.parseInt();

  // If the next character is a '/' it means we have an URL
  // with a value like: "/digital/13/1"
  if (client.read() == '/') {
    value = client.parseInt();
    digitalWrite(pin, value);
  }

  // Send feedback to client
  client.println("Status: 200 OK\n");
  client.print(F("Pin D"));
  client.print(pin);
  client.print(F(" set to "));
  client.print(value);
  client.print(EOL);    //char terminator

}

if i do http:///arduino/webserver/ i get that

and if i do http:///local/webserver/ i get that

Thank in advance for you help!

did you replace with IP?

Yes

what is in debug log in web panel?

master - 2016-03-16 - 2c5e217
88> Flash config restore ok
88> CONN led=14
88> Wifi init, mode=STA
88> WiFi: ERROR ssid default changed
89> Wifi uses DHCP, hostname=UnoWifi1
89> "ip": "0.0.0.0"
89> "netmask": "0.0.0.0"
89> "gateway": "0.0.0.0"
89> "hostname": "UnoWifi1"
89> sleep enable,type: 2
89> Serbridge pins: reset=12 isp=4 swap=0
90> Reset cause: 3=soft wdt
90> exccause=4 epc1=0x40210250 epc2=0x0 epc3=0x0 excvaddr=0x0 depc=0x0
90> Flash map 4MB:512/512, manuf 0x01 chip 0x4016
90> ** esp-link ready
91> initializing MQTT
91> MQTT_Init
91> initializing user application
91> waiting for work to do...
91> mode : sta(5c:cf:7f:11:92:34)
91> add if0
213> scandone
214> state: 0 -> 2 (b0)
217> state: 2 -> 3 (0)
220> state: 3 -> 5 (10)
220> add 0
220> aid 5
220> cnt
287>
287> connected with Livebox-6170, channel 5
287> dhcp client start...
288> Wifi connected to ssid Livebox-6170, ch 5
1091> ip:192.168.1.30,mask:255.255.255.0,gw:192.168.1.1
1092> Wifi got ip:192.168.1.30,mask:255.255.255.0,gw:192.168.1.1
1092> host_name = UnoWifi1
1092> server_name = _arduino._tcp.local
2348> Sat Feb 29 08:42:30 2020
2348>
10220> pm open,type:2 0
15089> Wifi check: mode=STA status=5
604891> Sat Feb 29 09:42:32 2020
604891>

as I remember the request should be logged. but there is nothing, so it didn’t reach the arduino.

did you use the same IP address in http:///arduino/webserver/ as for the web panel?

Yeah, i really don't understand why it doesn't work :confused:

with other networking libraries I get connection reset in browser if I send the response before the request is read completly.

try to add client.find("\r\n\r\n"); after String command = client.readStringUntil('/');

Did I do wrong?

it is only a warning.
the find function has not the right parameter type since it exists, but it works.

In any case it still doesn't working :confused:

With the same code i tried it in Chrome / Firefox and from two computer but it's the same
"This site is inaccessible"

are you sure the sketch is uploaded? on screenshot it was only 'Verify'

I tried with a simple code to light up the led it's actually working so ( i tried 2/3 different code to be sure ). it was one of my assumption but for me the sketch is well upload like the other

so it simply doesn’t work. I tested it and it can handle the /arduino/digital/ requests but can’t it return the page. I tested all 3 versions of the factory firmware. this is a work of arduino.org.

I used the Uno WiFi Dev Ed in 2017 a while with the factory firmware, buy I only sent one number to set as PWM.
Then I replaced the firmware for the WiFiLink firmware. I used that a year, then I replaced the Arduino in my project.

After the arduino.org ended, I maintain the WiFiLink firmware. It is not very good (arduino.org work too), but it works. (The other Arduino WiFi libraries including the new WiFiNina are not much better. They are all based on same code written for the old Arduino WiFi library)

Now I use the Uno WiFi Dev Ed as Uno or as esp8266, or with AT firmware to test my WiFiEspAT library.

So I am the guru for Uno WiFi Dev Ed, but I can’t help you with the factory firmware.
Your options are WiFiLink firmware with WiFiLink library, or AT firmware with my WiFiEspAT library.
My library is better, but the AT firmware can run only one TCP server.

It is a great board. The only special thing about Uno WiFi Dev Ed compared to Uno with an esp8266 module wired to SoftwareSerial pins is the use of I2C Serial converter to wire the esp8266. I wrote a new driver for it, because the original worked only at 9600 baud.

Everything about Uno WiFi Dev Ed is here GitHub - jandrassy/UnoWiFiDevEdSerial1: Implements Serial1 of Arduino Uno WiFi Developer Edition board to access the on-board ESP8266

Thank very much for all of your reply from what i have understand i my code doesn’t work and i should use your At firmware to try your Library i started to check how to do that i think i will take several day to understand but i will try that ^^

Which version i should download please ?

1.7.2

upload in IDE EspProxy sketch from "Uno WiFi Dev Ed Serial1" library examples

download https://github.com/jandrassy/UnoWiFiDevEdSerial1/wiki/files/esp_init_data_UnoWiFi.bin

then in folder of the AT firmware binaries

esptool.py write_flash --flash_size 2MB-c1 0x0 boot_v1.7.bin 0x01000 at/1024+1024/user1.2048.new.5.bin 0x1fb000 blank.bin 0x1fc000 esp_init_data_UnoWiFi.bin 0xfe000 blank.bin 0x1fe000 blank.bin

Sorry but i can't see EspProxy.ino i'm doing something wrong probably xD

Nooskya:
Sorry but i can't see EspProxy.ino i'm doing something wrong probably xD

install the "Uno WiFi Dev Ed Serial1" library?

so i uploaded EspProxy i changed the file in bin

but the i blocked on the next step