Arduino Yun PiP installation

Hi there, I've been trying to install pip on my arduino yun for the last two days and nothing seems to be working, all the resources I find seem to be 3 to 4 years old so I'm not sure if it just requires a different method or what but this is my problem:

I've tried following the guide posted here: Installing Pip on the Arduino YUN

Following that guide I get an error that says "unknown url type https" when I try to run "easy_install pip". Which after some googling I find out is a result from not having an ssl library. But I did install python-openssl

After having this new problem I kept googling around finding very little help until I eventually found this post: http://forum.arduino.cc/index.php?topic=187319.msg1548183#msg1548183
(If this link doesn't work properly it's quoted below)

This post says to try the following:

DrSpeed:
FWIW, to get openssl/python to work I installed the following packages (in order).
I'm positive you don't need all these packages but I'm prettyer sure you need pyopenssl before openssl will install.

opkg install bzip2
opkg install unzip
opkg install tar
opkg install wget
opkg install fdisk
opkg install e2fsprogs
opkg install openssh-sftp-server
opkg install distribute
opkg install pyopenssl
opkg install python-openssl

After trying this I still get nothing.

My final solution was to just download pip manually and install using "python setup.py install". I downloaded pip, placed it onto a micro sd card, and once I ran the command it still didn't work because it said I didn't have enough space for pip. But this arduino is new and I've downloaded nothing onto it yet besides a sketch to test it out.

Does anyone have any idea how to get pip working

Got it working

For anyone who might stumble upon this issue, the fix was a factory reset and updating openwrt as shown here:

After that, following this link from my earlier post got it working: