Arduino Yun with PoE keeps rebooting and crashing when powered via PoE

The board model is DHQAR-W03 and I think it is the Version 4 as everytime I connect the Ethernet Cable I keep hearing a High Frequency Whistle.

The interesting thing is when I power the board via USB Cable I can see the WLAN and WAN LEDs blink and I can SSH into the Yun via both the media (Ethernet and WiFi)

However Whenever I power it via the PoE, I see the lights of the WAN blinking on and off for a while and then suddenly the USB white LED blinks again indicating the board is restarting.

According to this thread ( the whistling can be solved by soldering a 100uF Electrolytic Capacitor to the PoE adapter but I am not sure whether this will solve the problem.

There is no way I can debug this problem via the Linino OS as every restart causes the dmesg ring buffer to reset. However I tried pinging the Yun while it was powered via PoE and found that I receive just a handful of pings and then the board is again unreachable and so on.

What are some possible troubleshooting methods to look into this. The whole Point of PoE is that I don't want to use USB Cables.

Please let me know if you need further information for reproducing the problem



Arduino Yún with PoE that I have has the Adapter from Silvertel AG9600 1R Adapter on it. As mentioned in the thread ( I soldered a 100µF 16V capacitor to PIN 7 and PIN 8 of the Adapter and the everything is working great.

PIN 7 --> Capacitor Negative
PIN 8 --> Capacitor Positive

Should help anyone facing this problem.


For someone who might not know how to find the polarity of a electrolytic capacitor, here is a Reference (