Arduion BT can't find bluetooth serial service

Hi My bluetooth arduino is behaving a little erratic. I can only discover the arduino when I reset the module, ie. after bootloader led flashes. same as for pairing. once the bootloader stops waiting i can't find the arduino. i don't think this is normal? then my bluetooth stack can't find any services on the arduino. I expected to find a bluetooth serial port? so i can't connect using the arduino software as there is no serial port. using Windows XP SP2 and broadcomm bluetooth stack. any suggestions would be very welcome thanks

hi

what do you have connected to it?

Check the batteries first, I know it's a simple thing but this is often the probelm .

D

thanks daniel right now i have a 3v regulated power supply attached while i test things. i had a protoshield with led attached to pin 13 and potentiometer on analogue in 2, to test, but even with these removed i still can't find any (serial) services on the ArduinoBT.

hi jmak

One idea... have you tried a slightly higher supply voltage, say 5V?

another idea is based on how the module operates. The BT resets the Bluegiga module when it starts up. I have seen BT's without a program go into a continous cycle of resetting when they don't have a program loaded-- the bootloader just cycles.

What exactly happens with yours? Do you lose the BT connection to your machine right after the bootlaoder is finished? Does it come back shortly thereafter? Can you still program it over the BT connection?

one final not is that there are known issues on connecting to the BT while using high port number on windows. D

hi daniel thanks, i tried 5v, but still the same. I can detect the BT and windows think it is paired, but i can't find any services for the arduino, so can't connect or program over bluetooth. i tried on another PC but it also had trouble detecting the arduino and couldn't pair. i have had it connected before and could upload ok. not sure what caused the problem. could it be an upload that didn't complete properly? anyway, can't get serial service now. COM port is 5 at the moment. when i turn the BT on, i get about 5 quick flashes then ~8 second pause then 2 flashes. then nothing visible. cheers jmak

hi

that is not so good if it won't program... to verify that it's not a windows issue, you should find a Mac and try it, as the Mac will pair up easily and reliably.

D

(PS: if you don't have a MAC, just go into one of those Ikea-looking internet cafes in the middle of any big city and ask one of the hipsters with a Macbook if you can test your Arduino :)

;D i'll get them to buy me a coffee as well. probably a lesser evil that taking over his/her shiny new macbook pro. great idea.

BT problems for me too!
Running OSX 10.4.8 and 009 IDE version,
power the board with 5,5 V (+/- 0.2 V),
using a Sharp IR range sensor on analog input 0.

I can easily pair the BT board and managed to read analog input data from the IDE serial monitor,
but ONLY IF I open the serial monitor RIGHT AFTER hardware resetting the board with the switch,
just as you do to upload code to the board.
If I power the board and try to open the serial monitor after, say, 5 seconds, I got the discouraging message:
Error inside Serial.()
gnu.io.PortInUseException: Unknown Application
at gnu.io.CommPortIdentifier.open(CommPortIdentifier.java:354)
etc…
I need to place 2 BT boards far away from the pc so I can’t push the reset button on the boards
everytime I want to start the serial communication.
I don’t think it’s a power issue, coz once it’s connected and going, it’s stable for hours and hours
(tried to keep it working all night long and the board behaved perfectly).
Is there a known solution to this problem?
I’ve seen that the Diecimila board has a sort of automatic reset switch
and that maybe even the BT board can be modified, but I’m a bit afraid of frying everything!!!

Second problem: I need to read data in Max/Msp,
got all the code working and communication is ok when I use the USB Arduino,
but it seems that Max/Msp can’t open the BT connection to the board on its own:
I noticed that the only times (out of countless trials) it worked with BT
was when I managed to open the connection using the IDE serial monitor
and then start Max/Msp while the connection was kept open by the IDE,
then close the SerialMonitor in the IDE, and voilà, the data was there happily flowing in Max/Msp!!!
Didn’t have to do all this hassle with the USB version, cos it’s a Bluetooth issue, I guess.
A bit ankward solution but the only way I found to use it.
So this seems to be the right procedure:
Power BT board
Open Arduino IDE->Start SerialMonitor,
Hardware reset BT board,
ONLY AFTER the connection is estabilished and working (->you can read the data in the serial monitor window)
open Max/msp and start serial reading,
then close the SerialMonitor in the IDE and start rocking.
Anyone got a better method???
Can’t max/msp open a connection by itself when you start reading serial data with its “Serial” module?
Searched on the maxmsp forums but got no clue about that.

Last question: :o
Can I render the BT board invisible to other devices other than my computer?
I don’t want people try to connect to the board while it’s working!
even if they can’t acces it I suppose that the connection BTboard<->Computer
could be affected by, say, cellphones or laptops in the area trying to connect to the BTboard…

That’s all for now, sorry for the extra long post!
Any help would be REALLY appreciated,
hope this post was useful to someone,
have bright days,
gio

the problem I have seems to be just like the one mentioned in the beginning. I can discover and connect to my device but the arduino software does not allow me to select the port that the bluetooth has been connected to. If it does, it only shows for about 5 seconds then dissapears. I have been using high port numbers so I will try it with a lower number now, and possibly a mac if i can get my hands on one.