Atmega32A fuse bits set (help needed)

hi all,
i just got an issue with my Atmega32A chip , i've tried to set the fuse bits for using an external oscillator ,then the chip doesn't respond.
the setting i think is good .
here is what i set the fue bits to :

for High fuses : 0b11011001

OSD                --->  1
JTAG               --->  1
SPI                 --->  0
Watchdog        --->  1
EEPROM          --->  1
bootsize          --->  0
............         --->  0
boot reset       --->  1

for Low fuses : 0b11110111

CKDIV8        --->   1
CKOUT         --->   1
SUT1            --->  1
SUT0            --->  1
CKSEL3         --->  0
CKSEL2         --->  1
CKSEL1         --->  1
CKSEL0         --->  1

i also use a 16Mhz external oscillator with 22pf ceramic caps for the external clock signal !

would it be a wrong fuse bit set , or me having a bad clock signal ?

note: i also tried to generate a squared signal of more then 1Mhz in the XTAL1 pin with an arduino board , but the board still doesn't respond .

i keep getting these errors when ever using the avrdude with this chip :

avrdude.exe: warning: cannot set sck period. please check for usbasp firmware update.
avrdude.exe: error: program enable: target doesn't answer. 1
avrdude.exe: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

avrdude.exe done. Thank you.

any guidance/help would be very apreciated !
best regards,

Your fuse bits seem fine, there are some online fuse bit calculators available which you can use to verify them.