avrdude: stk500_recv(): programmer is not responding

I know there are a lot of these posts. This is indicating that this error condition is too broad and must provide more information.

Arduino: Sparkfun Pro-Mini ATMega 328 (5V) OS: Mac OS X 10.6.8 Arduino s/w: 0022 cable: FTDI 5V5

For a review of the steps taken to get this error see this video: http://www.youtube.com/watch?v=Iij6FWCrGqw

There must be something going on with this configuration that avrdude doesn't like.

Thanks, Jon w1jp

I know this is probably not helpful and obvious* but I think I would give it a shot. That board appears to have an external FTDI. If that is true, make sure it is connected tightly. Also be sure you have selected the correct board on the Arduino menu.

*Not sure I spelled that right :grin:

Hi w1jp,

I had that same problem with my arduino fio. I read at arduino.cc that error has to do with the rts and dio3 pin on your explorer. So if you solder those pins the error should be solved. I tried that on my explorer and it worked out for me even though now I have a different problem.

Hope that helps.

I have this same problem with my brand new Sparkfun Ethernet Pro board. http://www.sparkfun.com/products/10536 I'm on Mac OS 10.6.8 with Arduino 0022 and I also use the 5V FTDI board they sell. I've loaded the latest VCP drivers from FTDI's site. I've selected the correct port and processor. I'm powering from the USB port. The board lights up as expected. I'm attempting to upload the simple Blink sketch as a test, and get this error. Same thing with any other example sketches.

The kicker is, this setup works fine with my other unit, the Sparkfun Arduino Pro 328 board. http://www.sparkfun.com/products/9219 That bad boy has the same processor and everything. I have no reason to believe this is a problem with the board - the bootloader works as shown in the video w1jp provided. My board also appears to have a test program pre-loaded which runs the Ethernet module. It's lighting up the LEDs and appears to be attempting to connect to Ethernet, so it's not DOA.

It would really be helpful if someone would post their resolution to this problem. I'm not looking for "gee, I don't know, but you should try X-Y-Z" but rather a solution someone has found for the problem. Thanks, everybody.

Hi Guys, If I am not mistaken, from the video, and the descriptions (especially as PMsteve has a working board, and a none working board) it sounds like a boot loader error. Or a sync issue due to incorrect board selection.

I am not certain about the solution that Avi mentioned. Seems reasonable, however the FTDI basic should not need modification to work. It is definitely functional as it comes from Sparkfun.

Feel free to email Tech Support @ Sparkfun . com if you have any more questions.