avrdude: usbdev_open(): did not find any USB device "usb"

I'm having trouble uploading a sketch on my Pro mini AT328 5V 16 MHZ that I got from SparkFun.

I'm using an FTDI TTL-232R-5V-WE cable that supplies 5V. I have wired it up as follows: green - green yellow - TX0 orange - RXI red - VCC brown - GND black - BLK

If i try to upload in "verbose" mode by holding down the shift key then pressing upload i get this: avrdude: usbdev_open(): did not find any USB device "usb" If I do it in normal mode I get this: avrdude: stk500_getsync(): not in sync: resp=0x00

I have tried pressing the reset button at various times.

I have done the loopback test posted at the top of this forum, that FAILED. However I have also done my own loopback test by jumping TX and RX and CTS and RTS, that PASSED. I don't know what this means.

I have set the "set RTS on close" in the advanced settings on the COM port.

I have verified the Board setting in the IDE. I have tried Pro mini / pro at328 5v 16mhz as well as what was suggested in the troubleshooting guide of using Duemilnove at328.

I have verified the com port is correct in the IDE setup

I have Verified the drivers are up to date for the FTDI cable-at least according to Windows 8.1 - Does 8.1 suffer from the same ailments as Win7?

I have tried two different Pro Mini's and one of my Pro's

All three seem to have a bootloader installed because I do get a blink on the LED when I press the reset button. They came from SparkFun if that makes any difference?

I have tried most of the above on my windows XP machine as well with the same results.

I don't know what else to try. Any Ideas?

I bought a Lilypad Snap thingee from sparkfun a while that had the demo sketch, but no bootloader. Didn't break out the SPI pins so no way load the bootloader without a special TQFP adapter. Do you have a working Uno? Can set that up as an ISP and put a bootloader onto your Promini's: http://www.gammon.com.au/forum/?id=11635

Could also try updating the FTDI driver: http://www.ftdichip.com/Drivers/D2XX.htm Win x64-bit (or 32-bit, but not likely with newer machine) Another member reported success with this yesterday.

These are the only Arduino's I have. I do have a few jtag programmers for Silicon labs parts and NXP. I'll see what else I have and maybe contact SparkFun too.

The Arduino IDE needs the VCP driver doesn't it? I'm using the latest version of the Arduino IDE 1.0.5-r2.

Just reporting on what another member said worked. I have win7pro, cannot confirm/deny win8/8.1 operation.

I downloaded the VCP and the D2XX, either way windows is convinced i have the most up to date driver. The Driver version in Device manager for my COM port does match whats listed on FTDI's website as being the latest. 2.10.0 I guess all that left is to get the bootloader reloaded....


I disconnected the Brown wire.. no change.

EDIT: I tried it on my Win8.1 and my XP machine, still nothing. The Arduino IDE 1.0.5-r2 on Win8.1 is REALLY slow. I do not have any of the Bluetooth serial drivers mentioned in one of the troubleshooting guides. I went ahead and disabled my Bluetooth radio anyway since I don't use it, its still slow..

I am having the identical problem with using my sparkfun ftdi device to program my pro mini board "avrdude: stk500_getsync : not in sync: resp = 0x00". I have ordered two different versions of the pro mini and both devices exhibit the same unwillingness to be programmed. My sparkfun device did work successfully on a bare atmega328 with the arduino bootloader.

It seems I have been using the wrong cable. I thought mine was a USB to TTL. It appears that it is actually a USB to RS232. I have ordered a TTL version and will have it tomorrow. I will report back once I get it.

The TTL cable works as it should. case closed for me.

By the way, the reason the loopback test I mentioned earlier failed was because I missed the step of connecting TX and RX together.