board not recognized

Hi everyone,
i am an arduino suuuper nooob. I bought my first board to play and get more interested in it.

I have to say this is not an original board, it is a compatible one.

I have a question: why i can’t upload my sketch?

this is the message i get while uploading program:

avrdude: Version 6.3, compiled on Jan 17 2017 at 12:00:53
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is “C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf”

Using Port : COM1
Using Programmer : arduino
Overriding Baud Rate : 115200
avrdude: ser_open(): can’t open device “\.\COM1”: Impossibile trovare il file specificato.

avrdude done. Thank you.

I followed the instruction and i select the arduino/genuino UNO board from list.

I also installed the ARDUINO UNO driver in Windows 7 (x64) Device Manager

Thanks everyone for helping.
Bye,
Marco

Select the port of your Arduino from the Tools > Port menu. If the menu is disabled or the port of your Arduino is not shown on the menu:

  • You may need to install the driver for your Arduino
  • You may be using a charge only USB cable
  • You may be using a defective USB cable
  • You may need to switch from using a USB 3.0 port to a USB 2.0 port on your computer

Thanks for your reply.

Actually, USB cable was connected to usb3.0 and i moved to a 2.0 port, but the problem still exist. I guess it is a driver issue. I tried many drivers but the answer is the same:

unable to start the device (cod.10).

PS: usb cable is a printer cable...

SOLVED!!!! i found this page:

Thanks for your time!

bye
Marco

thanks gund77! it was a problem and solved by you. thanks a lot.

(when i upgraded from windows 10 to windows 10 creators my old usb drivers -i suppose- were reset to original. now its normal. arduino sketches are uploaded successifully)