Burn to Bootloader

Hi all!

Wondered if anyone could help?

I am currently trying to burn boot loader to my ATMega328P-PU Chip. I followed the instructions on the Arduino site using an internal clock.

My actions:

  1. Open arduino software, open Arduino ISP sketch, I check the correct comm port and board to ‘Arduino Uno’. I upload this and it works fine.

  2. I disconnected the Arduino, wire up the circuit using breadboard. (Attached below).

  3. Connect to Arduino back up and change the programmer to Arduino ISP. I burn boot loader and receive error

'avrdude: Yikes! Invalid device signature.
Double check connections and try again, or use -F to override
this check.

I have looked all over the internet to find an answer but can’t seem to fix this. I have tried a new arduino, new ATmega chips which are the correct ATmega328P-PU. New jump leads, new usb and tried it on different software versions for arduino.

Any suggestions are much appreciated?

Thanks,

SimpleBreadboardAVR.png

Follow Mr. Gammon's discussion here: http://www.gammon.com.au/forum/?id=11635