Cannot run "make" when using Eclipse IDE for Arduino

Hello,

I am new to Arduino, although I have done several other types of microcontroller projects using the Eclipse environment (so I’m more used to using that IDE). I am trying to configure Eclipse to work as my IDE for future Arduino projects, and have been having a hard time. I have tried the following three methods to configure eclipse:

  1. Followed the instructions provided here: http://playground.arduino.cc/Code/Eclipse
  2. Tried using the arduino plugin for eclipse provided by Jantje here: Arduino Eclipse IDE named Sloeber - Welcome!
  3. Exactly followed the instructions provided here: http://horrorcoding.altervista.org/arduino-development-with-eclipse-a-step-by-step-tutorial-to-the-basic-setup/

In all three cases, I followed the instructions verbatim, and ended up with the exact same result. When trying to actually build the project, I get the following message in the CDT Build Console:

13:17:04 **** Incremental Build of configuration Debug for project TestProject ****
make all 
Cannot run program "make" (in directory "D:\Documents\Arduino\TestProject\Debug"): CreateProcess error=2, The system cannot find the file specified

13:17:04 Build Finished (took 5ms)

No compiled object is generated. Does anybody know how to resolve this issue? It almost looks like eclipse cannot find the compiler. I have verified in all cases that the PATH variable (under preferences->C/C++ Build->Environtment) includes <arduino_install_directory>/hardware/tools/avr/bin. The avr-gcc executable does reside in that directory.

Eclipse automatically generates a makefile in the directory “D:\Documents\Arduino\TestProject\Debug” which calls avr-ar in order to make the object libTestProject.a. Does this error message mean that eclipse is unable to find the makefile itself, or that when running the makefile, it is unable to find the compiler invoked within?

I appreciate any help! Thanks,

Paul

Cannot run program "make" (in directory "D:\Documents\Arduino\TestProject\Debug"): CreateProcess error=2, The system cannot find the file specified

That's pretty self explanatory. It can't run make, because it cannot find it. Is make installed? If so, is it in your path?

Thank you for the prompt response! I didn't realize "make" was a separate program that needed to be installed. Do you know where I could go to download "make" for Windows 7? I had ensured the compilers were installed and included in the PATH variable, but not "make" itself.

Paul

http://gnuwin32.sourceforge.net/packages/make.htm

Thanks again - I realize these are probably 'no duh' type of questions :)

I installed 'make,' and it resides in 'C:\GnuWin32\bin.' I added this to the PATH variable (under preferences->C/C++ Build->Environment) for the project, and it still gave the exact same message when trying to build. Do I need to set a global (to eclipse) environment path variable instead of the project specific path variable somewhere? If so, I'm not sure how to do that in eclipse.

You do it in Windows. I forget exactly where as I’m in Linux. Try this: http://www.computerhope.com/issues/ch000549.htm

That fixed it!

For any windows users reading this in the future, setting global environment variables in Windows 7 is done by right clicking 'Computer,' then clicking 'Properties,' then selecting 'Advanced System Settings.' From there click the 'Environment Variables' button on the bottom, and under the 'system variables' box find the PATH variable. Then, click on it, click the 'Edit' button, and add the new install path to the end of it separated from previous paths by a semicolon.

Thank you,

Paul