Cannot run WifiNina Firmware Update sketch

I tried to update the firmware for the NINA W102 BLE module on my custom Nano IoT 33. I had a clone of this device designed and assembled, but with a few extra ICs, and I left out the Crypto chip and the IMU.

I followed the instructions here: https://www.arduino.cc/en/Tutorial/WiFiNINA-FirmwareUpdater (WifiNina 1.5.0 library installed - the latest). Every time I hit “Update Firmware” (see screenshot), I get an error message, “Programmer Not Responding. Make sure that FirmwareUpdater sketch is loaded on the board.” even though I have successfully loaded the sketch. (Also by the way, I have the latest version of Arduino IDE (1.8.13)).

To dig deeper, I uploaded the sketch via a debugger, and found that it is stuck in this loop of the FirmwareUpdater sketch:

if (!ESP32BootROM.begin(921600)) {
Serial.println(“Unable to communicate with ESP32 boot ROM!”);
while (1);
}
The closest available solution on the internet to this problem is here https://forum.arduino.cc/index.php?topic=654833.0 and it did not work for me (still receive the same error, and I think that solution is outdated anyway).

It looks like it’s having trouble connecting with the BLE chip and I can’t figure out whether it means I’ve designed the PCB wrong/the manufacturer made a mistake during assembly (unlikely because I triple checked the Nano IoT 33’s circuit schematic, but it’s still possible) OR I’m doing something wrong software-wise. Can someone please advise? And please keep in mind I’m an Arduino newbie (but long term software developer)!

No replies? Did I post in the wrong section?

Hello, I posted this topic and couldn’t get any responses in the forum. I’m looking to pay for an hour (or few) of someone’s time to take a look at my issue with a custom Arduino board I had developed. https://forum.arduino.cc/index.php?topic=692774.0

If you’re interested, experienced, and think you can help, please let me know your availability and rate.

Problem is, everybody wanting to help will need the board you are using. I'm sorry, I don't have it. If I did, I could help :slight_smile: