Cannot see any Arduino on Mac running High Sierra

I've had this problem for a long time now but was always content to just use a virtual machine but now I need to get it fixed.

The problem is, when I plug in any of my Arduino's (they are all clones), and look under the dev folder, I never see any usbserial device. However, when I go to system report, I can see it there as a generic USB 2.0 device, and I can assign the device to a virtual machine and use it from a VM, but it never shows up on my mac as a usable device.

I can use other USB devices without any issues at all, even USB to Serial adapters work (like when I'm consoling into a Cisco router for example).

I tried replacing the IOUSBFamily.kext with one from the original install .DMG file, and I tried installing the latest CH34X drivers (1.4 I believe) without success.

Anyone out there have this issue who was able to solve it?

Thank you,

Mike Sims

Are you saying that the arduino board does not being defined by the computer ??