Fix for serial port not showing up on Macs running Sierra or High Sierra macOS

Folks,

I’ve recently had problems with a serial port not showing up on my MacBook Pro running the latest rev of macOS High Sierra. After much investigation, it appears to be a bug in Apple’s own AppleUSBACM (Version 5.0.0) driver/kext. Here are the details and two workarounds as I reported to Apple’s support forum:

https://discussions.apple.com/message/33079474#33079474

HTH,

Mike

PS: The simpler workaround is just to reboot your Mac with the Arduino already connected, but that can get tiresome :slight_smile:

Thanks for posting this. total newbie waiting on order but a 10.3.3 user.

Hi,

Well i just downloaded the Serial app and it indeed does something to view the serial port and it connects fine and receives data from the arduino nano i have plugged into it because i can see the data in the terminal screen of the Serial.app, but when i go over to the arduino ide the port is not there, so I cant really do anything else except see the response from the old sketch i had on that nano.

Ive rebooted the macbook pro 2x and still the arduino IDE doesnt see the port.

mikew67:
Here are the details and two workarounds as I reported to Apple's support forum:

https://discussions.apple.com/message/33079474#33079474

This link no longer exists.

Any update on this? Happened to me too..

@mikew67 I am also having this issue and your Apple support link no longer exists - would appreciate if you could share the workarounds you found directly!