Cannot update firmware, programmer not responding

So I’ve been trying to update the firmware on my Wifi101 Shield, Model ATWINC1500-MR210PB
It’s on firmware 19.4.4 and need to upgrade to 19.5.2 due to a bug that is fixed with making HTTP requests.

I have tried every which way to update the firmware. I tried the built in Firmware updater, but it just says “programmer not responding” whenever I try to test the connection or update the firmware. I tried opening the example sketch for updating firmware first, but still the same result. I also tried updating the firmware through the command-line, but that also fails as it just hangs at a certain spot (I forget off the top of my head).

I even bought a 2nd WifiShield as I thought maybe I bricked the first one, but still the same result. I’m really frustrated and at a loss here, so any help is greatly appreciated. This is the exact chip I purchased: Wi-Fi Shield (ATWINC1500) | TinyShield |


Just to confirm, you've followed all the steps in the guide here?

What board do you have the WiFi101 shield connected to?

Edit: WiFi101 shield has a model A chip on it, and the latest firmware it can run is 19.4.4.