Can't Connect ESP8266 to IDE

I recently purchased an ESP8266 and am trying to upload some code to it and keep getting the error:
serial.serialutil.SerialException: could not open port ‘COM3’: FileNotFoundError(2, ‘The system cannot find the file specified.’, None, 2)
I have tried selecting several of the different ESP8266 boards but nothing seems to change. I can also plug in my Uno to the same USB and change the board to Uno and it works fine.

From the sticky at the top of the forum section:

Hardware:
We need to know exactly what hardware you have. We need to know what Arduino board (or other brand, such as ESP32) you are using and exactly what other hardware you are connecting it to. The more details we have the easier it is to help.

If you are using something that is a non-Arduino product then it helps to have a link to its technical data sheet or a link to where you bought it.

There are dozens of ESP8266 boards. Absolutely no idea which one you’re trying to connect to and there are three different usb to serial bridge chips that could be in your exact board.

Ok it is a HiLetgo ESP8266 NodeMCU CP2102 ESP-12E

Does the SiLabs CP2102 show up in your usb device list?

Could be wrong but you typically need to load a driver for that usb chip.

No, it doesn’t show up on my usb device list. Is there something I need to download for it?

https://www.silabs.com/developers/usb-to-uart-bridge-vcp-drivers

I downloaded that and it’s still not working or showing a CP2102 on my usb devices
image

Oops, my bad. The CP2102 needs to appear under the COM/LPT tab in Windows (not a win guy).

Sweet. I found it there, but I’m still getting the same error.
image

That worked actually. Thanks!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.