ESP8266 NodeMCU LUA CP2102 ESP-12E COM port not present.

Hi,

I used Arduino Uno V3 before without any problems. This is my first attempt to use ESP8266 NodeMCU LUA CP2102 ESP-12E .I am using Arduino IDE 1.8.7. On Windows 10 Professional.
I have successfully installed ESP 8266 in the IDE, but I can't upload code to the board because COM port is missing. The board is connected with USB cable to the computer, but COM port driver does not get installed. There is no COM port listed in the device manager. I can see that the board is powered up. There is 3.1V present on 3V3 pin and LED is flushing when I press "Reset" button. The system, however doesn't seem to recognize the device. I tried installing driver from here: CP210x USB to UART Bridge VCP Drivers - Silicon Labs,
but it did not solve the problem. Am I missing something here?

Some additional information: When I use usbview utility from WDK, with Aarduino Uno V3 connected to USB, I see “Arduino Uno” on the appropriate USB port (see the attachment). With ESP8266 connected I don’t see anything. It looks like the unit doesn’t get registered on USB. I tried two boards with the same result.

USB_Dump.txt (2.35 KB)

OK. This happened to be a defective cable. Sorry for this.