Can't update driver on Nano clone

I bought a few Nano clones last year. One was programmed, but I had to reinstall Win 10. Now the Arduino driver for the boards does not install. When I plug one in I get Serial 2.0 under ports with an exclamation mark, but when I try to update it from the downloaded driver files. none work. Advice?

Peter

I think that with an exclamation mark, there usually is also an error message. Please post it.

Which TTL-to-USB chip is on the board(s)? If not sure, right click the port in Windows device manager, click properties, select the details tab and next from the dropdown box select hardware ids. It will look like below

Report the VID and the PID (or look them up on the web) to find out which chip you have.

Actually it is a red triangle. Nothing under details. Here is a screenshot of properties.

OK, in that case it will be visual inspection of the chip on the bottom of the board.

I bit of a guess is that it's the CH340 in which case I would try to download the driver from CH341SER.ZIP - Nanjing Qinheng Microelectronics Co., Ltd., unzip it and run the exe.

If it's anything else, let us know.

Example, not from a Nano, that shows the CH340

1 Like

@PABresler you can try downloading and installing the latest FTDI driver

  1. Download the driver executable file from FTDI's website here into the Arduino drivers folder on your computer and run it from there.
  2. In the dialogue box that opens, extract the executable installation file.
  3. On the FTDI CDM Drivers dialogue page, click on Extract.
  4. Click on Next in the Device Driver Installation Wizard dialogue page.
  5. Thick I accept this aggreement and click Next in the Licence Agreement dialogue page.

Click Finish to complete the installation

The CH341SER.exe worked! I was able to program the Nano. Thanks a lot!

Peter

1 Like

There is a solution checkbox under each reply. Tick the one under the most useful reply to let others that have the same problem know that your problem was solved.