Genuine Nano will not connect

I purchased a Chinese clone nano and installed the CH340 drivers and was not satisfied with the results. I just received a genuine Nano and I can not get it to connect to my computer. I have done the following: uninstalled the CH340 drivers, uninstalled and reinstalled the IDE, tried three different USB cables and both USB ports on my computer (Windows 10 64 bit), tried multiple options to update the drivers using the Device Manager.

The nano powers up and the Device Manager shows "Other devices / FT232R USB UART". After spending the afternoon, I am now getting this window when trying to update the drivers, "Windows found drivers for your device but encountered an error while attempting to install them USB Serial Converter The hash for the file is not present in the specified catalog file .The file is likely corrupt or the victim of tampering". Any help will be appreciated!
20210819_154912|375x500

Your cheap Nano clone uses the CH340 chip for USB, The Real Nano does not use this chip.The Nano uses the FTDI FT232RL chip for FTDI.

Remove all CH340 drivers, The Arduino IDE comes with proper drivers for the Arduino Nano. You might have overwritten the drivers. Try resetting your Arduino and loading the blink example and try to upload the sketch and test. If it now works you are ok. If not you may have to re-download the correct drivers.

Good Luck with your project

I went directly to the FTDI site and downloaded and installed their driver package. The nano now recognizes the port, finally.

This problem exists for the "genuino" Nano boards as well. The drivers in the current Arduino software (both .exe and .zip versions) will not install on Windows 10. Manually trying gives the same "the hash for the file is not present". Other sources indicate that this is due to Windows device driver signing.

Downloading the latest drivers directly from FTDI will allow a proper installation of the drivers.

You can still use the built in drivers.
WIN 10 has driver signing turned on by default.
The drivers are still signed AFAIK but win 10 is more strict than previous versions of windows.

Hi @perockwell. The FTDI drivers bundled with the Arduino IDE have been updated in the latest 1.8.16 release. You can download it here: