Can't upload sketches onto the board

Hi, I am a newbie to Arduino, here is what happened:
I am running Arduino atmega386 on PC with Win 7 through USB.
I tried uploading either something I wrote or the blink example through either one of 4 COM virtual ports recognized at the Tools>serial port item - nothing worked (‘not in sync’ error). Later, I connected the board to a Mac with OS X 10.5, also tried both sketched through either one of 4 recognizable ports, nothing worked (‘programmer not responding’ error). When the board is connected the green LED is lit constantly while the yellow one blinks rapidly as it should. The RX/TX LEDs never light on.
I would appreciate any tip… thanks!

Do you have the correct board selected in the IDE?

Thanks for the reply. Yes, the correct board is recognized by the IDE.

:) :) :) Got it to work! didn't do anything special, simply connected it and suddenly the computer recognized it, automatically installed a driver (thought it was serial COM3), so in Tools>Serial port> I checked COM3 and voila :) Thanks for the help.