capteur de contrainte

bonjour,

j’ai besoin de suivre les modification de masse d’une cuve
cette cuve sera posée sur un support mais celui ci ne sera pas forcément bien horizontal.

je suis donc parti sur des capteurs de contrainte de ce type :

je pensais en mettre 4 à chaque coin de mon support

la sortie ne faisant que 3mV je dois relier chaque capteur à un amplificateur ina125P

Vous comprendrez vite que si la programmation n’est pas un soucis pour moi, la partie éectronique est beaucoup (beaucoup, beaucoup) plus obscure

j’ai bon ?

comment dois je cabler tout ça ?

merci

Felix83: bonjour,

j'ai besoin de suivre les modification de masse d'une cuve cette cuve sera posée sur un support mais celui ci ne sera pas forcément bien horizontal.

je suis donc parti sur des capteurs de contrainte de ce type :

http://www.gotronic.fr/art-capteur-de-force-100-kg-czl301c-19653.htm

je pensais en mettre 4 à chaque coin de mon support

la sortie ne faisant que 3mV je dois relier chaque capteur à un amplificateur ina125P

Vous comprendrez vite que si la programmation n'est pas un soucis pour moi, la partie éectronique est beaucoup (beaucoup, beaucoup) plus obscure

j'ai bon ?

comment dois je cabler tout ça ?

merci

bonjour oui le INA125 dipose de sa propre sortie "excitation" INA125 et arduino un exemple http://edg.uchicago.edu/tutorials/load_cell/

conseil : utiliser Vref5V du iNA125 pour ARF arduino

faire une recherche avec https://www.google.fr/#q=ina125+arduino+load+cell

merci j'ai lu entre autre, ton post sur le sujet

je n'avais pas le lien UChicago

il faut un Ampli par jauge ou bien les 4 jauges peuvent rejoindre le même Ampli ?

merci

Felix83: merci j'ai lu entre autre, ton post sur le sujet

je n'avais pas le lien UChicago

il faut un Ampli par jauge ou bien les 4 jauges peuvent rejoindre le même Ampli ?

merci

faire du multiplexage de µV est possible, mais AMHA le jeu n'en vaut pas ici la chandelle un INA par jauge est plus simple à mettre en oeuvre

merci

pas d'autre conseil ou mise en garde sur ce genre de montage ?

a+

Felix83: merci

pas d'autre conseil ou mise en garde sur ce genre de montage ?

a+

rien de + A part bien soigner la connectique et son cheminement entre les jauges et l'INA et mettre une R ajustable pour le gain de l'INA en lieu et place de la R fixe

c'est ce que j'étais en train de lire par ailleurs

dans le schéma de l'UChicago c'est la R 1K entre les pattes Rg c'estça ?

autre question idiote : il ne me semble pas possible de plugger directement l'ampli INA125p sur la breadboard existe t'il un composant qui puisse le faire ou dois je jouer du fer à souder ?

Felix83: c'est ce que j'étais en train de lire par ailleurs

dans le schéma de l'UChicago c'est la R 1K entre les pattes Rg c'estça ?

autre question idiote : il ne me semble pas possible de plugger directement l'ampli INA125p sur la breadboard existe t'il un composant qui puisse le faire ou dois je jouer du fer à souder ?

oui pour la RG si tu le prend en boitier DIP, tu peux le plugger directement, mais la destinée de ce genre de compo n'est pas de finir sur un breadboard, mais sur un vrai circuit , n'oublie pas que tu joue avec des tres faibles signaux.

merci

c'est juste le temps de tester tout ça ... je suis du genre à faire griller les composants ...

merci pour tout

a+

Felix83: merci

c'est juste le temps de tester tout ça ... je suis du genre à faire griller les composants ...

merci pour tout

a+

:grin: en meme temps , c'est un peu aussi la bonne saison pour les grillades 8) -------->[]

slut je viens de reçevoir mon capteur et mes amplis

le capteur c'est ça :http://www.gotronic.fr/pj-903.pdf l'ampli est un INA215P

j'ai monté comme ça :

si j'ai bien les yeux en face des trous, mon captuer doit être alimenté en 9v donc la différence par rapport à ce shéma c'est que les fils R et N du capteur sont sur une pile 9v

j'ai commencé avec un R220 puis j'ai mis un potentio 0-500 réglé à 50

malgré tout, j'ai ce genre de résultat : (cf pièce jointe)

une idée ?

merci

la pièce jointe : le résultat de la console série (tempo 100 milli)

resultat.txt (8.11 KB)

Felix83: slut je viens de reçevoir mon capteur et mes amplis

...

si j'ai bien les yeux en face des trous, mon captuer doit être alimenté en 9v donc la différence par rapport à ce shéma c'est que les fils R et N du capteur sont sur une pile 9v

j'ai commencé avec un R220 puis j'ai mis un potentio 0-500 réglé à 50

malgré tout, j'ai ce genre de résultat :

une idée ?

merci

bonsoir je ne comprend pas "bien" ton schema :grin: et ta doc (ce n'est pas un datasheet) est bizarre (mauvaise traduc ? ) regarde plutot celle là http://www.phidgets.com/documentation/Phidgets/3138_0_Datasheet.pdf

la mise en oeuvre est simple : tu excite ta jauge au travers du INA125 (choisir le meilleur compromis des 4 possibilités = alimenter INA au dessus ) tu calcule RG pour obtenir à pleine echelle une amplitude maxi (compatible arduino) . et tu utilise l'INA 5V (ou -) comme AREF pour l'arduino

bon, on oublie tout ce que j’ai dis avant, j’avais un pb d’alimentation de ma BreadBoard !!! :0 :0 :0 :0

j’ai tout revu, et j’alimente mon capteur avec la pate 4 de l’INA125p (soit le 5v)

maintenant, j’ai des valeurs

mais en relisant le certificat livré avec mon capteur, je vois que la tension RECOMMANDEE pour le capteur est entre 9 et 12v

j’ai donc cablé le pin 16 et le 4 ensemble pour alimenter le capteur en 10v

cf pj ina125p

et je lis sur A0 la tension de sortie des pins 10/11 de l’INA

avant d’aller plus loin, j’ai 2 questions (qui sont liées) :

j’ai mis un potentio 0-500 en RG. Actuellement il est réglé sur 150

la tension de sorttie de mon capteur est donnée pour 3mV/V
question 1 (pour une buse …) cela veut il dire q’avec une alim en 10v j’ai 30mv en sortie ?
question 2 (toujours la buse) : quel lien avec le poids posé sur le capteur
question 3 (ben oui j’avais dit 2 …) : pourquoi l’analogread(A0) me renvoie 14 alors que sur mon DMM (réglé à 200mV) je lis 62.5 ?

merci

Felix83: ... avant d'aller plus loin, j'ai 2 questions (qui sont liées) :

j'ai mis un potentio 0-500 en RG. Actuellement il est réglé sur 150

la tension de sorttie de mon capteur est donnée pour 3mV/V question 1 (pour une buse ...) cela veut il dire q'avec une alim en 10v j'ai 30mv en sortie ? question 2 (toujours la buse) : quel lien avec le poids posé sur le capteur question 3 (ben oui j'avais dit 2 ...) : pourquoi l'analogread(A0) me renvoie 14 alors que sur mon DMM (réglé à 200mV) je lis 62.5 ?

Bonjour reponse rapide (à approfondir plus tard) et les interventions du dimanche sont facturées doubles :grin: 1- oui 2- le lien est la relation d'amplification , cette relation depend de la valeur de RG comme tu utilise une reference de 5V pour AREF arduino (au passage utilise la sortie ref 5V de l'INA) , il faut "simplement" pour une masse de 100 Kg caler RG pour une lecture de 1023 sur A0 (perso je calerais 1023 pour 102.3 Kg 8) )

3 . peut etre parce que c'est normal ? 8) à la louche le pas d'acquisition d'un arduino en AREF 5V est de 0.0049 V 14 X 0.0049 = 0.0686 et compte tenu des dispersions 62.5 mV/68.6 mV c'est "parfaitement" dans lec clous 8)

Merci je remets 2€ dans la machine pour compléter :

1- je dois comprendre que ce que je lis en A0 de l'arduino ce n'est pas la tension de sortie mais le "nombre de pas" de lecture ?

2- tu me conseilles d'utiliser le Vref 5v de l'INA (soit le pin 15) plutôt que la sortie Vout (pin 10 et 11) ? pourquoi ?

merci

Felix83: Merci je remets 2€ dans la machine pour compléter :

1- je dois comprendre que ce que je lis en A0 de l'arduino ce n'est pas la tension de sortie mais le "nombre de pas" de lecture ?

2- tu me conseilles d'utiliser le Vref 5v de l'INA (soit le pin 15) plutôt que la sortie Vout (pin 10 et 11) ? pourquoi ?

merci

-1 oui -2 non je crois que tu n'a pas bien compris le fonctionnement de l'INA

Avec l'INA tu dispose (à la condition qu'il soit au moins alimenté à 10V +1.25 , le plus simple et pratique en 12V) de tensions de references disponibles en 2.5 ,5 et 10 V

  • tu utilise la sortie 10V pour exciter ta jauge et la sortie 5V comme reference de tension pour l'arduino pin15 de l'INA vers AREF de l'arduino , en oubliant pas de declarer dans ton programme
analogReference(EXTERNAL);

il ne te reste ensuite qu'à definir le gain avec RG pour obtenir 5V (1023 sur A0) avec 100 Kg de charge (ou 102.3 pour simplifier la suite)

merci je n'avais pas noté qu'il me fallait alimenter l'Ina en 12v. je vais chercher une alim 12v quels sont les conséquences de l'alimentation en 5v?

par contre je ne comprends pas le point 2 : pourquoi définir une référence externe qui va définir la tension de référence à 5v alors que par défaut la tension sur A0 est de 5v?

a

Felix83: merci je n'avais pas noté qu'il me fallait alimenter l'Ina en 12v. je vais chercher une alim 12v quels sont les conséquences de l'alimentation en 5v?

par contre je ne comprends pas le point 2 : pourquoi définir une référence externe qui va définir la tension de référence à 5v alors que par défaut la tension sur A0 est de 5v?

a

bonjour en standard la tension de reference est = à la tension d'alimentation de l'arduino et cette tension d'alimentation n'est PAS une reference de tension fiable, elle fluctue/varie fortement avec la conso instantanée, la source d'alim et d'autres parametres. l'ina125 lui te fourni une vraie reference de tension, simple à utiliser , il suffit simplement de le declarer dans le programme

Merci

n’ayant pas d’alim 12 v sous la main j’ai utilisé une 15v. L’INA acceptant jusqu’à 36 ce doit être OK

si je débranche l’Arduino et le V+ u capteur j’ai effectivement 15v sur le V+ de l’INA et respectivement 10, 5 et 2.5v sur les pins 16,15 et 14
tout va bien
si je branche le V+ du capteur sur le 10v de l’INA, la tension alors mesurée sur ce pin (16) n’est plus que de 5.6v et, la Vref 5v (pin 15) de 2.6

est ce normal ? par ce que du coups, l’Arduino ne reçoit pas du 5v sur l’AREF

au passage, mon capteur ne réagit plus : il reste à 0 et passe à 1023 si je retire l’alim.

merci