CH340 driver

Hi,
I’ve bought a chinese Arduino Nano and tried to install the CH340 (Windows 10, 64 bit), but every time I click on the install buttton, the pop up says successful pre-installation. Then when I check in the device manager, there isn’t any change and there is no port in the Arduino IDE. Could someone help me, please?

Výstřižek.PNG

Do you see a device in Device Manager appear under the “Ports (COM & LPT)” section after you connect the Nano to your computer?

No, I don't see it there, only one red diode is on on the arduino and one is blinking.

Make sure the USB cable is completely plugged into both the Arduino board and the PC.

You may have a damaged/defective or charge-only USB cable. Try a different cable.

Either of the above can result in the power connections being made (and thus LED lights on the board), but no data connections (and thus no port for the board).

Thank you, I’ll try it

(deleted)

Yes, I've tried restarting the computuer after the installation. Yeah, that's probably the only thing I'm sure about :smiley: